Xcp-ng installer fails to run

Trying to install xcp-ng 8.2.1 on my Intel NUC 12 Extreme.

It boots (see the strings of text scroll down the screen), but when I suspect it is supposed to load the installer, I get a blank screen. Literally nothing on the screen.

I came across this possible solution. Unfortunately with the same results.

I have tried the installer with the alternate kernal, both with and without the above modifications.

I am using a USB stick with Ventoy, so I am able to easily try both the stock ISO and the ISO I modified with the above changes.

Unfortunately, the option to disable UEFI boot is greyed out in the settings (and I haven’t figured out to make it available), so I am unable to try legacy boot.

I have tried running a few Linux installers, and they booted into the installer fine.

Any ideas for me to try would be greatly appreciated.

Just for fun, try imaging to a different USB so Ventoy won’t be in the way. I had an issue with one image through Ventoy and XCP-NG might have been the one.

Thanks for the idea. I’ll let you know how it goes.

Just tried both the unmodified & the modified ISOs (using to create the bootable flash drive).

I have tried both ISOs with the USB stick formatted to use GPT & MBR partition scheme.

Unfortunately, still no luck.

Although I don’t think any of the changes I made should cause this, I’ll try changing all of the BIOS setting back to default (minus disabling secure boot), see if that does anything.

As much as I would like to get it up & running, if resetting to defaults works, I will see which setting(s) are causing this issue.

Since my searches haven’t come up with any other solutions. Now I’m ready to throw stuff and see what sticks.

I will document everything I have tried, and the results.

I had exactly the same issue i don’t know how i got it working but i did something that mysteriously got legacy booting option to work in the bios

Interesting. So judging by your experiance, it seems xcp-ng doesn’t support UEFI boot. Their installation instructions on their website mention UEFI boot mode. Just not the ones on our machines lol.

At least I have another area I can focus on (the BIOS).

I’ll reset mine to default, & document my changes. @anturk I’ll let you know which option enables that option for future referance.

Thanks for all your suggestions.

I just checked my messages with a friend of mine this is how i got it working i guess

Alright i got it working. So i updated the bios and there was a extra button for more options to put it in legalcy mode. After that it worked. I’m not sure till how far it worked because i saw it has some errors but the server is installed en running.

Well, I’m borked. I just came across an article that Intel is phasing out support for legacy BIOS boot mode, & will only support UEFI bios mode.

That being said, it doesn’t mention NUC 12 at all. My bet is it doesn’t.

So if that’s the case (that there’s no way for me to enable it), I won’t be able to use the legacy mode solution.

Unless someone has come across a way to get xcp-ng to boot using UEFI on the newer Intel firmware, I might have to look at Proxmox (although I was looking foward to learning this), at least until Intel UEFI bios mode support is added.

Thank you for your assisstance.

This is odd, the installer does indeed say that UEFI install of the host is supported. Have you asked on the xcp-ng forum?

I’d like to say I can test this on a server, but I just don’t have the time right now. I’m still thinking that this is the automatic UEFI/legacy boot mode thing that most of these computers use for compatibility. I’ve seen several Linux install confuse the hardware and fail to boot after install.

Can you lock the firmware into UEFI only, might work, might waste more time.

There is a bunch of stuff on this page, apparently there may be a workaround: XCP-NG Intel NUC 11 - #8 by Terence_Smith - Hardware - Level1Techs Forums

No. I just came here.

I’ve gone through every sub-menu and option. That’s the only option related to UEFI boot.

Thanks. I’m downloading the test ISO. I’ll keep you posted of the results

To be honest i get it why they did it but it’s also kinda stupid because they know which people are using the Nuc lol

Yeah the Intel Nuc that i was talking about was the 10th generation. But keep us posted i hope you get it to work because XCP-NG is super cool but otherwise Proxmox is also a great option.

Test2 ISO works.

My new issue is its not detecting my network interfaces and won’t continue with the install without the driver(s).

I just noticed that Andrew’s page that has the Test2 ISO also has the RPM drivers for the network card. What’s odd is, I just looked in the ISO, and all of those are in the Packages folder. Yet when I press F9 to load drivers, nothing shows up.

I even put the 2 I (think I need) in the root of the thumb drive, still nothing.

(This was with Ventoy)
Then for shits & giggles, I tried Rufus so it was direct (with the same RPM packages). Same.

I can only select [Local media]

I then get a message saying “no XCP-ng compatible drivers were found at the location specified. Please check the address was valid and/or that the media was inserted correctly, and try again.”

I even tried a seperate USB stick with the packages.

Note to self, don’t buy a NUC.

Just for fun, have you tried Centos 7 in whatever the latest version might be? XCP-NG is built on C7 still, you might find some solutions this way. But then again, not exactly making life easy which pushes you to a different product.

It seems like support for Intel NUC gen 10+ are a work in progress. Probably by v8.1.4 at the earliest they will be supported. Also, as Vates has mentioned in the forum, it’s basically up to the community to get it working, as the XCP-ng team are focused on [enterprise-grade] server hardware.

Only if you want to run XCP-ng. Window$ and regular Linux distros work fine.

I have not. But if I’m spending this much time on it, I’ll give it a whirl just for shits & giggles.

I’ll keep you posted.

Update: CentOS 7 DVD ISOs no network devices found. Downloading the 9.6GiB “Everything” ISO.

Update 2: No dice with the “Everything” ISO. It seems like its an upstream issue with CentOS.

Update 3: Just checked LMDE for a debian-based system. Wireless not detected, only detects one of my Ethernet ports. If I had to guess, it’s probably the 2.5Gbps port, and not the 10Gbps one.

Just tried Proxmox. It detects both Ethernet ports, but not the wireless.

Interesting. :face_with_raised_eyebrow:

Summery of findings on Intel NUC 12DCMi9:

Proxmox
+ Boots fine
+ Detects both LAN ports
- Does not detect the wireless card

LMDE
+ Boots into the live environment
+ Only detects a LAN port (so can still able to access repo to download additional drivers)
- Wireless not detected, so limited in connectivity

CentOS 7
+ Boots to installer fine
- None of the network devices recognized

XCP-ng
- Must use a test ISO to get to boot to the installer
- None of the network devices recognized & will not allow you to proceed without any devices present

I’m curious as to weather XCP-ng will eventually move to Stream, or if they will switch to a CentOS 7 fork (eg. Rocky).

Looked at the documentation. It only says “here is the point where you install drivers”. Nowhere does it mention how, or even referance to somewhere else for an explanation.

I will be installing Proxmox, since it at least recognizes my ethernet ports.

I will keep checking back every release (and time permitting, how to install drivers during install).

I was hoping to get my server up and running (and ideally all my services too) this long weekend, but now that’s not happening. :disappointed: