Won't stay suspended

Good Morning Everyone, Happy FRIDAY!

I have am having an issue with my Ryzen based system that I can’t seem to figure out. When I put the computer to sleep it powers down and goes to sleep for about 1 second before it wakes back up. I have unplugged every USB device I can, the network cables, and it still wakes up as soon as I put it to sleep.

I reinstalled ARCH linux thinking that maybe an update broke something but even with a fresh install (I tried it as soon as I finished the install) it wakes immediately without any outside action.

I have tried looking through dmesg but nothing stands out (but I’m not 100% certain what I am looking for).

Any suggestions of what I should be looking for? I’m happy to post redacted logs, etc if it helps with the troubleshooting.



System Specs:

Ryzen 7 3700x
Gigabyte B550M DS3H AC
16GB G.SKILL Aegis 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600)
Crucial P2 500GB 3D NAND NVMe PCIe M.2 SSD
XFX Radeon 5500XT 4GB
Vanilla ARCH linux fully updated Plasma Desktop

I don’t use Arch, might want to try their forums https://bbs.archlinux.org/

That was going to be the next place I headed but I like the people here so I thought I would start here first and see if anyone else has seen this behavior.

1 Like

This is Interesting indeed. Ryzen is unparralled in its class imho.