Unifi Controller Cloud (VPS) Backup problems

Hello, guys I’m getting an error when i try to do the backup.

[2019-07-15T13:29:02,609] ERROR system - Fail to create a backup for version ‘5.10.20’

[2019-07-15T13:29:02,609] <backup> ERROR system - Info on backup error is... java.lang.NullPointerException: null at com.ubnt.ace.D.o00000(Unknown Source) ~[ace.jar:?] at com.ubnt.ace.D.o00000(Unknown Source) ~[ace.jar:?] at com.ubnt.ace.D.o00000(Unknown Source) ~[ace.jar:?] at com.ubnt.service.OoOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.J.o00000(Unknown Source) [ace.jar:?] at com.ubnt.service.OoOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.Z.o00000(Unknown Source) [ace.jar:?] at com.ubnt.service.OoOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.Z$_ooo$1.run(Unknown Source) [ace.jar:?] at com.ubnt.ace.D$3.run(Unknown Source) [ace.jar:?] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_212] at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_212] at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:1.8.0_212] at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:1.8.0_212] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_212] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_212] at java.lang.Thread.run(Thread.java:748) [?:1.8.0_212]

[2019-07-15T13:29:02,611] <backup> INFO system - [server backup][BACKUP] end

[2019-07-15T13:29:02,612] <backup> INFO event - [event] Backup failed

Any idea im using Current Version 5.10.20 (Build: atag_5.10.20_11657)

what platform are you hosting this on? Ive had some strange issues with AWS but restarting the server or compacting the database worked for me. You can also try to backup “settings only” unless you absolutely need the data.

I’m using DigitalOcean. the problem is that I CANT make the “settings only” same error.
Autobackup option also dosent work.

have you tried compacting the database?

i will try that. @sysman923
Also is there another manual method to do a backup?

I’m pretty sure there is a way to run the auto backup from SSH but I have to look. You can as a last resort ssh into the VPS and navigate to /var/lib/unifi/backup/autobackup and it should have a few files in there with .unf extension…you can copy those to you pc and restore if you need to.


Also, make sure there is enough space on the server.

i dont have any files there @sysman923 i tried that yesterday.

  System load:  0.32               Processes:           90
  Usage of /:   28.8% of 24.06GB   Users logged in:     0
  Memory usage: 84%                IP address for eth0: xx.xxx.xx.xxx
  Swap usage:   10%


let us know after you try to compact the DB and restart the server.

also what version of unifi is the controller?

Current Version
5.10.20 (Build: atag_5.10.20_11657)

Question… @sysman923
If I have multi-sites on my cloud controller I have to make a backup of each site?
Or just going to Setting > Maintenance > Download Backup this will do a backup of all sites

That will backup the whole controller which includes all sites. If you are moving to a new server or VPS you will likely get a new public IP so make sure your devices are connected via FQDN (bobsunifi.bob.com).

Ok perfect let me get home to compact the database since i get this message.

Are you sure that you want to compact the database? There could be service interruptions during the process.

nahhhhhhhh do it its fine…i think…

Compact database feature doesn’t solve the problem… any other advice.

@ninjoan check out this link for repairing the database

Yes, I follow that guide yesterday without success. I’m starting to lose the hopes.

what are your options for moving it to a new controller? I did my 2019 controller about a month ago on AWS and it took about 30 min to move 15 sites.

I’m scared an out moving to a new VPS without losing any site or equipment.

Maybe doing a site to site migration Old Vps - New VPS.

Also, need to be sure the new VPS is well set up to prevent this problem again.

I can’t find any information about this error which leads me to believe that it is a really edge case. Moving to a new controller is super easy, watch one of @LTS_Tom videos of setting up unifi controller on the cloud.

As far as the migration process is concerned here are the steps I go through. Please make sure you use a FQDN and not an IP

  1. create a new blank controller -> make sure you put your FQDN unifi.yourdomain.com under Settings > Controller > Controller Hostname/IP
  2. confirm you can ping the new controller from your PC & use the Debug terminal in a few devices from each site to test ping to the new controller. Site 1 pick an AP or a Switch and open terminal and ping unifi.yourdomain.com (hopefully that’s good).
  3. Export the site - Settings > Site > Scroll down to bottom > Export Site
  4. Go to your new controller and import the site from the sites drop down in the top right
  5. After about 2 min & all devices showing connected go back to the other controller and Forget Devices

repeat for other sites.

If in the off chance you have a site where a device does not migrate don’t worry. Use the debug terminal of a device that is connected to the new controller and ssh into the problem device. You can grab the last ip that it had by going to the old controller and looking more than likely it is still the same.

1 Like