Strange Problem with Windows 10

Hello everyone,
I have what I consider to be a strange networking problem. I am running Pfsense community addition. I have created 3 VLANS. I am running 2 old HP procurve 2510-48g switches. Each of the VLANS are working as they should. All of my computers receive the correct DHCP information. None of my windows 10 machines can access the internet, but the raspberry pi and the other Linux machines can. The windows machines do have acess from the default lan. With the Linux machines able to access the internet, I feel I have a windows setting issue.
Any advice would be much appreciated.

Have you set a DNS server for your 3 DHCP scopes? Windows is quite reliant on that being correct from experience, while I noticed that Linux often tries a bit harder to resolve itself.

Guessing the vlans are untagged for the Windows machines? Think Windows is a bit blind to vlans, while Linux can detect them? You may also have to set the outbound vlan tag on those ports. I forgot what it’s actually called, but I remember having to do this

Does the Windows machine get an IP? DNS? Correct Gateway?

Yes. When I view the Ethernet settings from windows, the Ipv4 DNS server is listed as witch is correct for that segment.
On the switch, the “Computer” ports ( Vlan 10) ((2, 4 ,6, etc) are all set as follows:
Vlan 1 (default v lan) - No
vlan 10 (Computers) - untagged
vlan 20 (IOT) - No
vlan 30 (electronics ) - no

Yes the windows machines get good DHCP records.
They get correct IP address
DNS and gateway are correct
I am unable to ping anything outside of the network from the windows machine, but I have full internet access from Linux. With out touching any cabling, or adjusting any settings, I booted a thumb drive with Ubuntu, and I had good internet access.

What do you get when you execute the following commands from Windows command prompt

  1. nslookup (this is to check if your DNS is able to resolve correctly and also to find which is the default DNS it is using)
  2. nslookup (this is to check if you can connect to a DNS server located on the internet)
  3. Also on pfsense -->Diagnostic–> Routes. Check if there is any custom route created for the windows PC IP range.

Best way to trouble shoot if its DNS issue is to manually change DNS setting under network adapter property > Internet Protocol Version 4(TCP/IPv4)>use the following DNS server addresses: to say and Post this if you can connect to internet then your pfsense DNS is not properly configured.

I would like to say thank you to everyone who is attempting to help me with this problem.
Here are the results from Junu’s suggestions:
DNS request timed out
time out was 2 seconds
server: unknown
Address (This is correct for this vlan.)

DNS request timed out
time out was 2 seconds
Server: unknown

Routes from pfsense: link#7 U 3419332 1500 bce0.10 link#7 UHS 0 16384 lo0

I also tried abhay9’s suggestion, the result is the same ( to test used nslookup again)
nslookup ( new user restriction)
DNS request timed out
timeout was 2 seconds
server: unknown
I think I will “try Ubuntu” from a flash drive and report back the results from nslookup.
Thanks again all of you for your help

I was able to get my laptop to boot Ubuntu 20.0.4 I am running the live version from a thumb drive.
I and on the internet, I am able to browse to any site I wish and I have the results from nslookup.


non-authoritative answer:
Address: 2607: and the rest of the ipv6 address

and the rest of the information is the same as above

This is the same Windows 10 pro machine I was using earlier. Same network cable same port on the switch. The only thing different is the operating system I am using.
My ipv4 settings in Ubuntu are as follows:
ipv4 address: ← this is correct my pool is -
default route : ← this is also correct
ippv6 address : omitted for brevity

I can get similar results with a raspberry pi, plugged into the same port on the switch.
I have another Ubuntu machine plugged into a different port on the switch and it is also able to connect to the internet with no issues. This problem only affects the windows machines. I don’t have any other machines with a different version of windows

in windows power shell or CMD run

route print

you should see as Gateway on the first line, if not you have configured ip4 settings wrongly.


yes, when I run route print, I see under the gate way column.

Can you share the ip4 setting of the adapter screen shot

I’m sorry for the cell phone copy, easiest way to do this right now.

Did you try setting your DNS to temporarily?

why do you have

Primary DNS suffix is what pfsense called it . I did not specify my own domain name

I did. changing it made no difference.

Long shot, but try disabling ipv6 on the windows network adapter???

I think its not from pfsense, you can try by removeing it from your windows install.

Go to

Control Panel > System > Rename This PC (advanced) {you will find at bottom}>Change>More>

Here under “Primary DNS suffix of this computer” clear the field and also select “Change primary DNS suffix when domain membership changes” and reboot.

I think this should help

Thank you for the suggestion. I did try disabling IPV6. The results were the same.