Post VM setup in XCP-NG

#1

After setting up several VMs, including a PopOS! in XCP-NG, I’ve installed the tools, but the resolution doesn’t expand beyond the 800x600 resolution. Are there extra steps to get a higher resolution? I know it’s something simple, just haven’t found it yet.

Are there other steps you recommend as well?

For my Windows boxes, they take many reboots to get working with all the Citrix devices but then they are fine. Just wish there was an easier way - or maybe I’m missing that too?

Thanks

0 Likes

#2

I have never tried running Linux based OS with a GUI in XCP-NG so I am not sure what video driver needs to be loaded. Their forums might be more helpful for that.

0 Likes

#3

Before I got my hands on this older MBP I was playing around with POP_OS! in a VM. I didn’t see any issues running it in the console on XCP. I’m running an old Proliant DL360 G5 with on-board graphics. I can dig in deeper if you need @IanMajor12 , but I was running all of it pretty much straight out of the box.

0 Likes

#4

Thanks @kingsolmn and @LTS_Tom for the info. After a little more reading, finally 1440x900 resolution.
I think maybe still need a driver, but much easier to navigate.

https://linuxconfig.org/how-to-increase-screen-resolution-on-xenserver-7-gui-virtual-machine-vm
also tried

And now I know where to find all my xcp-ng answers for next time.

Times came back for this info: 2

1 Like

#5

A few trips through the videos @LTS_Tom uploaded was all I needed to get up and running! Well, that and some replacement fans, extra RAM, and a few more drives (just cuz MOAR!!! lol)

0 Likes