Zoiper Over OpenVpn Does Not Complete Calls

I have Zoiper on my phone and laptop. I have a site to site openvpn connection between my home network and my office network. Zoiper works perfectly. I have a road warrior Openvpn connection that works fine besides Zoiper says its connected but when i call the call last 6 seconds and hangs up no voice or anything.

my open vpn rule on wan is
Protocol = IPv4 UDP
Source = *
Port = *
Destination = Wan Address
Port = 1196
Gateway= *
Que = None

From reading some suggestion when I was typing this title I made a called and looked at pfTop

In HOME IP:41750 OFFICE IP:1196 MULTIPLE:MULTIPLE 00:02:28 00:00:57 91 41287

I have made sure that my FreePBX is allowing the tunnel network

I just don’t understand, the site to site works fine and the roadwarrior vpn is almost identical and I can not get a call to stay connected.

While I cannot help you with your specific problem, I will take a moment to point out that running VIOP traffic over an encrypted tunnel is generally a bad idea. It also adds an additional layer of complexity that typically provides no value-add and in fact often times causes more problems than it solves. Your IP Phones should already be talking to your PBX via TLS.

Native SIP connections are not encrypted, use a VPN and configure it to connect in both FreePBX and Zoiper using TCP and it should work.

You are correct I should have said SIPS. I honestly can’t remember the last time I deployed a handset that wasn’t configured to use TLS.

Ok, well I figured it out thanks to LTS_Tom’s suggestion in “Review: Using Zoiper with FreePBX & OpenVPN on Android”. I went into SIP settings to enable TCP however it already was. But I looked in the general settings and my NAT settings did not have the tunnel network in there. I guess I forgot that I needed that tunnel network address in the FreePBX firewall and in the General SIP Settings as well. I guess that feels redundant to me, but that would be a discussion better suited for the Freepbx forums.

Thank you for the help