ZFS Pool is unavailable after renaming

I tried renaming a pool based on these steps but it made my pool inaccessible.

zpool export <old-pool-name>
zpool import <old-pool-name> <new-pool-name>

This caused my pool to show up as “Unavailable” with a red X in my pool list under the old name. I tried exporting the pool via the web gui and then reimporting the pool with my passphrase and GELI key (legacy encryption) but after selecting the disks it asks me to choose a pool but nothing is available.

However my pool still shows up under the new name when I run zpool status <new-pool-name>

Screenshot from 2021-01-31 08-49-10

How do I get this pool back? *

*It’s fine if I lost this pool since I recently just backed up this pool to a new set of disks so I was cavalier about running this operation but in the interest of knowing how to recover from a situation like this and for future finders of this thread, it would be nice to know how to get my pool back.

Ha, I just rebooted the host and now everything is fine.

I should just read more closely.