XO on Debian 10 install for https

I’ve installed XOA on a Debian 10 VM and tried to access the front end on https:// ip but no response. I have though found it at http://ip:443, so no https but using port 443. I configured the install script xo-install.cfg from XenOrchestraInstallerUpdater to operate only on https port 443 but obviously SSL is not operating.
This is the second time I have tried this install, including xcp-ng host setup, due to other problems (and being at the bottom of a new learning curve) but did not have this problem. Worked fine last install from this script.
All assistance appreciated in finding a solution gratefully appreciated.

Same problem here. I can’t managed to have complete update…

I think I have discovered the reason for my problem, your’s may be th same reason.
In creating the SSL certificate I did “mkdir xo” but did not cd into the directory. Thus my xo.crt and xo.key files were made inside /etc/ssl and not the xo subfolder. It was the subfolder (/etc/ssl/xo) that I used in the script xo-install.cfg.

I’ve copied the cert and key to the appropriate folder, so now in both locations, and restarted xo-server. Unfortunately this made no difference, so tomorrow I may have to re-reun the install script.

Hope you get it sorted too.

1 Like

As with many issues - this was “Human Factor”. I built the SSL keys in the wrong location to that which I entered into the xo-install.cfg script. Had to remove the existing /opt/xo directory and re-run the install script. All fine now. Thanks everyone.

1 Like

@DavidJ is there an error in the documentation you were following or did you just miss a line?

Was working from Tom’s video and missed the cd into the newly created /etc/ssl/xo directory before creating the ssl certificate. Thus the crt and key were in a different location (/etc/ssl) to that I put into the script (/etc/ssl/xo) following Tom’s video elsewhere.