Xerox scanning to a network samba share

This has been driving me nuts, perhaps someone else here has resolved this problem.

So I have a Xerox Workcentre 3335 printer/scanner/fax device which I am trying to save a scanned document to a samba share on the network.

I’ve setup a sambashare in openmediavault if I connect to it via the desktop I can save a doc with the user xerox.

shot01

The xerox setup:

No matter what combination of share name and document path I use, the scanner fails to save to the shared directory.

I’ve tried:
Sharename:
//192.168.20.206/smb206
//192.168.20.206/smb206/scans
//smb206
/smb206
smb://192.168.20.206/smb206
Document path:
/scans
scans
//scans

I’ve tried both 139 and 445 for the port.

The scanner does save to USB but not to ftp.

Any solution would be greatly appreciated

I would check which version of the protocol it is trying to use. I had an issue mid last year trying to get VMware vCenter 6.7 to save a backup config file, turns out they only support SMB v1!!! It been a while, but I think you can see the version negotiations if you capture the packets.

1 Like

Does your path need \\192… backslash? Depending on what xerox os is the slash may matter?

Does the xerox see the share just not save to it, or completely fail when connecting?

@Acestes thanks I think that it might be the samba version … I believe Debian10 installs v3 as default (I need to check). Yes I have a feeling if I can reset smb max to v2 it might work.

@Thedannymullen fair question but no idea, I did update to the latest firmware, though the error comes out as “File exists or the failure is unspecified”. Did try forward and backslash in the path. I suspect Xerox does not update their drivers but I had read they can rework Mac drivers for linux so not that much effort.

It’s pretty challenging to get peripherals working with Linux, I actually checked that they had Linux drivers before I bought the device, but they’re not as fully featured as windows ones.

@neogrid found this page, it may help (although it does not mention 3335 model)

@pavlos thanks trust me I have scoured every inch of Xerox’s site, I’m using a linux desktop and was considering setting up a windows server to see it I could get it to work.

I hate to be the one to ask but here goes… did you check your permissions? Went through something like this with a scan to file on a Sharp network printer-scanner-fax on a Windows machine with a small business client. Took 3 hours! Permissions had to be very specific!

@civilmann yeah it’s a fair point, I tried this on a headless debian server first, thought I may have messed up the permissions for the user but usually it needs samba and user rights, so I’ve set it up on OpenMediaVault which is a bit easier to get the permissions right.

Thought it might be smb versions, still failed on v2. Now I’m trying it on the same vlan.

I would still test it with SMB v1 easy enough to do with an old copy of Windows (or a new copy with it enabled). It’s surprising how many things still only use v1.

@Acestes in OMV I was able to set the minimum smb version to core (which I think is equal to v1) so in theory if the client was on 1,2 or 3 it ought to be able to talk with the server.

I did have the strange outcome where the xerox could now scan to an FTP share but I was not able to access the share from my desktop :sob: my gut feeling is that this is a versions issue on firmware/protocol/kernel etc.

I’m close to giving up on this nut…

We’ve got a larger copier from Xerox and the interface looks similar. Here’s a snip of my settings that are working

Only difference I see is the document path.

Have you tried changing it to /smb206/shares/

@gsrfan01 thanks for sharing the pic, still struggling with this but at least I can see the format of something that works.

@neogrid I’ve not used OMV, but I found this post which implies you have to do a bit more to get SMB v1 working https://forum.openmediavault.org/index.php?thread/29701-scan-to-folder-stopped-working-how-to-enable-smb1/ might be worth a shot.

thanks I had that bookmarked :slight_smile:

The permissions are a bit easier to see on OMV compared to the headless Debian I started with. My QNAP is setup for SMB and FTP and has been working for while, but I can’t get the Xerox to save to that either.

I’m beginning to think it doesn’t like Linux systems, I’m gonna try a Win7 for testing.

Certainly worth trying on a Windows system. You can use powershell to see the version that is running, but Windows 7 probably runs v1 by default. Of course you could just look at the packets in wireshark and see what is going on :slight_smile: