XenOrchestra Backup to Freenas NFS

I have XO installed and Freenas. I was trying to backup my VM’s to Freenas as has been discussed in various videos. I have setup a NFS on freenas and can connect it as a remote in XO. I test the remote in XO and everything seems fine. But when I try to do the backup of the VM I get an error that “no disks found”. I have also tried to setup a SMB on freenas. in XO I can also connect to the SMB as a remote, but also get an error that says “no disks found”. Any help on where I need to look would be appreciated. I have played around with permissions on the freenas share.

Thanks in advance.

Hi DLund

Connect to Xen Orchestra using SSH. Them try to copy a file in the NFS-Storage. The connect to the Frernas Box using ssh and look for the file. If everything is okey you can see the file or the terminal error for more help.

Good luck

Thanks for your advice. I did as you suggested and initially there was no difference. But I did come across the problem. To test the backup procedures, I made a small temporary VM. This VM did not have any SR disk attached to it. So when I tried to backup, it came back with an error of no disks found. When I tried a real VM, it worked. So my error as I should have thought more about what the error message was telling me. Again thanks for help as it eventually led to my finding the error.

You’re welcome DLund.
It is good to know that it helps to find a solution
Thanks for the reply