Xen orchestra - error creating remote for backup tast

Hello everyone,

I had the community version of Xen Orchestra and I had the backup working. I wiped that machine and started again. I now have 3 xcp ng boxes for my lab. I am able to mount nfs shares from my synology to store iso cd/dvd images to use for installation. However, when I tried to create a backup tast, I tried creating a remote (for backup) and I made it the same NFS directory/folder which I connect to all my xcp ng boxes, it fails every time. It failed first in permission denied. I forgot to add “volume1” in front of the folder I created. Once I did that then I am seeing a timeout error. I tried testing the connection but the error persists. I have enabled permission in both my synology boxes and added the IP address of all 3 xcp ng boxes as allowed addresses… I know it works because they can all read from the ISOS images of linux distributions to install. However, as a “remote” for backup, I am unable to connect where in my previous xen orchestra installation it worked fine.

This is the log I can see:
“shortMessage”: “Command failed with exit code 32: mount -o -t nfs /run/xo-server/mounts/9c1c2ebf-8128-445a-977e-78e106f36bf2”,
“command”: “mount -o -t nfs /run/xo-server/mounts/9c1c2ebf-8128-445a-977e-78e106f36bf2”,
“escapedCommand”: “mount -o "" -t nfs "" "/run/xo-server/mounts/9c1c2ebf-8128-445a-977e-78e106f36bf2"”,
“exitCode”: 32,
“stdout”: “”,
“stderr”: “mount.nfs: Connection timed out”,
“failed”: true,
“timedOut”: false,
“isCanceled”: false,
“killed”: false,
“message”: “Command failed with exit code 32: mount -o -t nfs /run/xo-server/mounts/9c1c2ebf-8128-445a-977e-78e106f36bf2
mount.nfs: Connection timed out”,
“name”: “Error”,
“stack”: “Error: Command failed with exit code 32: mount -o -t nfs /run/xo-server/mounts/9c1c2ebf-8128-445a-977e-78e106f36bf2
mount.nfs: Connection timed out
at makeError (/opt/xo/xo-builds/xen-orchestra-202206171150/node_modules/execa/lib/error.js:60:11)
at handlePromise (/opt/xo/xo-builds/xen-orchestra-202206171150/node_modules/execa/index.js:118:26)
at NfsHandler._sync (/opt/xo/xo-builds/xen-orchestra-202206171150/@xen-orchestra/fs/src/_mount.js:64:7)”

Anyone have a suggestion on what I can look at? I know mounting a share via NFS is possible so I know I am missing something as to why a remote will not connect via NFS. Thanks for the help to anyone.

Synology works better with SMB so try setting it up that way.

Thanks. I can it make it work and I am getting decent speed, depending on what I am doing. No less than 89 megs per second to about 103 megs per second over SMB. I was thinking maybe I can squeeze a bit more speed with NFS. I just got a used server which will have truenas scale and I will see if I can do NFS with it.