XCP-NG VM Creation issues

So i recently backed up everything off my Dell R710 server. Installed windows server 2019 to update firmware i couldnt through IDRAC. Performed a clean install of XCP-NG 8.0 and now i cannot create a single VM. After install of linux mint 19.3, Ubuntu 18.04 LTS and 19.10. installation process fine, eject media reboot OS never comes backup. i have attempted creating win 10 VM and cannot get to boot to a installation i have included screenshots. Also note i did attempt reinstalling XCP-NG. Only thing left i can think to do is delete the Virtual disk in the raid control Reinitialize and try again. Any help appreciated.

windows error


1 Like

Today i tried deleting the Virtual disk in the raid control Reinitialize and reinstall. No dice. I am out of ideas i have tried LVM, no lvm, bios mode uefi mode. Literally everything same result. image

1 Like

I don’t have much useful to add other than I use Xen Orchestra to administrate my XCP-NG and while it does have quirks generally it’s been easy to set up VMs. The odd time I have to drop down to the command line to hard stop/start a VM since the UI gets stuck in some in-between state that it can’t figure out if the machine is on or off. XOA might be worth a try for you.

Thats just the weird part about it in 7.6 i created hundreds of VM. In 8.0 it seems i cant do anything

I apologise I glossed over the fact that you were using 8.0. I didn’t even realize 8.0 was out. I am going to do some testing with it this week and see what I run in to before I upgrade anything.

1 Like

Cool Let me know what you find. In ditch effort to see if it was an issue with firmware updates jack something else up. I installed ESXI and was able to create a Linux mint and a win10 VM without issue. I think this is an issue with the update.

1 Like

Interesting enough 8.1 beta fixed some of the issues. Per Stormi with the xcp team https://xcp-ng.org/forum/topic/2509/vm-creation-issues-v8-0/4 this is appears to be a bug within ubuntu desktop. if anyone has this issue this from the linked thread stormi with xcp team to the rescue.

Stormi wrote:
"I reproduced the issue with Ubuntu 18.04.3.

To me, this is an Ubuntu bug. The gdm service fails to start because it can’t start Xorg. See errors in /var/log/Xorg.0.log in the guest.

I found two workarounds:

Another workaround that I haven’t tested: https://xcp-ng.org/forum/post/19625"

1 Like