XCP-ng Stack and SSH becoming unresponsive after trying to setup a OPNsense VM

Hi there thought I might try asking here, I’m struggling to get OPNsense DVD installer to properly boot within a Xen VM, the installer boots and crashes at somepoint, XCP-ng stack and SSH become unresponsive at random points before becoming infinitely stuck, only a hard reboot and forcing the OPNsense VM to halt will allow those services to be accessible, Other VM’s like Debian work fine… So far I’ve tried checking dmesg within XCP-ng only thing worth mentioning is that the XO and NFS for my ISO SR’s become unresponsive during this time (Their hosted on a separate machine functioning as they should).

I’ve tried configuring the VM both in UEFI and BIOS mode, I’ve also tried giving it more resources beyond a reasonable hardware configuration so I’m not too sure what’s causing this kuffle…


Supermicro X8dtt-hf+ running Special OEM Ami BIOS


Dual Xeon 5660

Sata 3 SSD

Latest Stable XCP-ng and Latest Stable OPNsense both disk images passed their validity checks.

Any help is greatly appreciated thanks.



I have tested OPNsense a while back but I only really spend time working with pfsense in XCP-NG.
They are both BSD based so it should work with the same setup.

I’ve solved the issue a little while back, it was definitely user error.

OPNsense expects the theoretical “LAN” to be highest priority when initializing and the theoretical “WAN” to be second…

Here’s a screenshot of the working method within XO…