XCP-NG Setup Issues

So I ended up getting all the same parts that Tom did in his most recent XCP-NG Ryzen build. same MB, CPU, and Memory. Bios is updated all the way. when I boot into my XCP-NG ISO can only get 10-15 seconds in before I get an error. tried looking at forums but cant seem to get a fix. was hoping somebody in here could point me in the right direction. This is my first XCP-NG build

It’s failing on the IOMMU so try disabling in the bios.

thanks for that! was a little tricky to find but it was in BIOS → Advanced -? AMD CBS ->NBIO

One other thing i’m running into which i think i heard steve talk on the live stream. with the 3600 memory, did you run into power issues? or voltage to be specific?

I don’t recall changing any voltage settings and we now have three of these boards. But we did update them to the latest BIOS.

still kept the memory at 3600MHz? i ended up getting the exact same thing from your parts list. I originally set it up with 3200Mhz sticks until the new ones came in and when i changed it to 3600MHz thats when i started getting issues. started getting this voltage sensor error

I think we have it at 3200, I will have to ask Steve.

After tons of googling, i was able to get this figured out. in order to utilize 3200Mhz or 3600Mhz you need to enable XMP. when you enable XMP, it sets the Mem Voltage to 1.35. the ASRockRack MB has a threshold alert if it goes over 1.32. You cannot change this threshold in the GUI or SSH of the IPMI. instead, i had to install IPMI Tools on a random ubuntu server i had. then run the following commands

command → ipmitool -I lanplus -H -U username -P password sensor|grep VCCM
Result → VCCM | 1.210 | Volts | ok | 1.020 | 1.080 | na | na | 1.320 | 1.380

the 1.32 is the upper critical (UCR) and 1.38 is upper non recoverable (UNR). in order to change these values i ran this command.

command → ipmitool -I lanplus -H -U username -P password sensor thresh VCCM ucr 1.38
then changed unr and 1.7.

Locating sensor record ‘VCCM’…
Setting sensor “VCCM” Upper Critical threshold to 1.380

Went into bios, enabled XMP and boom everything is working and no errors!

1 Like