Hello everyone!
I am having an issue with my XCP-ng/Dell Poweredge R610 and HDD’s.
The issue is that I have a disk(s) that is chirping, which indicates the drive is about to fail…
I cannot for the life of me figure out how to read smart data from the HDD’s!
The disks in question are RAID-5 - in a storage array (Dell MD1200).
I have attempted to read the data using a few tools in XCP-ng, I’ve booted up to a removable USB and tried there, I have looked all through the RAID controller and BIOS. Every test I run concludes that the device cannot read smart data from the hard drives.
I am lost, and while the data I store on the array can be moved off, I don’t know what to do in the meantime until it fails 100%.
At this point I’ve kind of thrown my hands up and just waiting for it to die.
Any advice on how I can read this data is welcome.
Are there some HDD’s that don’t have SMART Data? I did buy a few refurbs - could those be the culprit of lacking smart data? (They don’t sound like they are making the noise)
Am I able to read smart data on disks that are already in a SR?
Do I need to remove my RAID to read smart data?
Do I need to manually one by one remove the disks and buy a SATA to SAS adapter and test them that way?
I’ve been banging my head on this one for a while.
Please help!

Thank You!

I don’t think there is any way for the OS to see any drive stats because it’s being handled by the Dell Raid Controller.

1 Like