XCP-NG Orchestra

Good afternoon everyone, I have been using VMware ESXi and vCenter since version 5 thro 7. With the recent VMware Subscription models and Broadcom issues. I been thinking about switching over to XCP-NG, however I do have some questions. Does Orchestra or Center cost any money for the full blown setup? This is for my homelab but if all goes well I want to deploy this and use the Enterprise support for my company.

Thank you,
John H

It’s free if you compile if from source:

1 Like

The self compiled version is missing a few things, but the important core features are present.

If you do not want to build itself, Ronivay has done the hard work for you

GitHub - ronivay/XenOrchestraInstallerUpdater: Xen Orchestra install/update script

Scroll down to Image, you can import a vm image of Xen Orchestra

I’ve also using Jarli scripts to automate the installation of Xen Orchestra – does all the compiling and updating for you. You just need to run scripts on VM which xen orchestra is going to run on. I’m using Ubuntu Host although if I were to do it over again I’d probably choose Debian Host. Jarli seems to work closely with the xcp-ng team (Oliver and others).

I followed the video (great video as always, got me up and running no issues), as well as this Using docker containers on XCP-ng with Xen Orchestra CE step by step - YouTube to setup a Docker server VM.

I’m using Debian for the server. However, I’m having difficulty with installing xe-guest-utilities in order to run the command “xscontainer-prepare-vm -v vmuuid -u username” to link Docker with Xen Orchestra.

I didn’t see a repo I needed to add during my searches, as apparently xe-guest-utilities is not in the Debian repos. Other than that, I have Portainer up and running.

Any suggestions is greatly appreciated.

I haven’t tried the method I’m linking you to: https://techviewleo.com/install-xcp-ng-vm-tools-on-ubuntu-debian/ however it looks like you could install from cd-rom. Preferrably however you’d like you package manager to take care of everything.

Thanks. I’ll give it a shot when I get a chance.

This link has specifically for Debian & rpm-based distros. I followed the instructions, & it worked flawlessly.

Note: It seems the ISO [pre-loaded with] is now the only way on Debian & Ubuntu (thank you to @kevdog for this info) to install xe-guest-utilitis.

Note: This installed 7.30.0-11, whereas the xo-ce VM interestingly has 8.0.50-1 installed. Although that shouldn’t be too much of an issue.

Thanks for the assist @kevdog, that got me on the right track.

I didn’t notice earlier, but the ISO is already in Xen Orchestra. I just had to mount it and run the install script. Stupid me. :yum:

Yea I noticed that as well with my Ubuntu VM’s – installing through cd-rom (since guest-utilities are no longer in ubuntu repositories) installed

That’s interesting, considering all of the guides online seems to specifically use Ubuntu when it says to install xe-guest-utilities via the repo.

That being said, most of the articles are a number of years old. Hell, the article I used (and linked to) which was posted on the Xen Orchestra blog, was posted in 2016, no updates to the article, & no new articles (that I could find) relating to guest-utilities, xentools, or guest-tools.

The above article only talks about installing from the ISO. It does not even mention installing via the repos. At the bottom of the article, it says you have to use the ISO to update. All I know is the install.sh is copyrighted by Citrix.

I would have thought, if anyone would have updated instructions/guide, it would be them.

Meh, issue solved. That’s all what matters

I have XOCE installed in Debian 11 Stable and after not being able to get the guest tools installed reached out on the XCP-ng forums to have Oliver respond with a tip to enable the testing version of the guest tools which has been working great.

I’m also using Debian 11 Stable (forgot to mention that :upside_down_face:). The ISO included with XO works with no issues, no need to build that seperately. As kevdog mentioned, it installs, unlike the 8.0.50-1 that’s automatically installed when XO-ce built from source.

Tried building from source over the weekend on Ubuntu host – no dice for me. Couldn’t get it built. I wish I had more input than what was mentioned on the github page.

What part are you getting hung up on?

Trying to build with go version 1.18.

I’m getting the following error:

# golang.org/x/sys/unix
vendor/golang.org/x/sys/unix/syscall.go:83:16: unsafe.Slice requires go1.17 or later (-lang was set to go1.16; check go.mod)
vendor/golang.org/x/sys/unix/syscall_linux.go:2255:9: unsafe.Slice requires go1.17 or later (-lang was set to go1.16; check go.mod)
vendor/golang.org/x/sys/unix/syscall_unix.go:118:7: unsafe.Slice requires go1.17 or later (-lang was set to go1.16; check go.mod)
vendor/golang.org/x/sys/unix/sysvshm_unix.go:33:7: unsafe.Slice requires go1.17 or later (-lang was set to go1.16; check go.mod)
make: *** [Makefile:90: /home/kevdog/src/xe-guest-utilities/build/obj/xenstore] Error 2

My go.mod file is as follows:

module github.com/xenserver/xe-guest-utilities

go 1.16

require golang.org/x/sys v0.1.0 

I’m not sure which method you are using to build from source but this is what I use and it works every time

the only issue I had was it wouldn’t let me run xo-install.sh. I was prompted to use xo-vm-import.sh.

That is the only thing I did differently from what Tom did in the video. Following his video (with that change) I was able to get it up and running with no issues.

You may have needed to chmod the install script to include A+X for executable.