XCP-ng install failing

I try to install xcp-ng-8.2.0 (ISO / thumbdrive) but it keeps boot-looping …

UEFI or Legacy ? no difference …

then I tried to install Linux mint (also from ISO / thumbdrive) as a test, installs and works without any problem … huh ?

… only the XCP-ng installer keeps boot-looping (beeps and cold reboots)

I quickly took a pic of the screen …

what is going wrong ?

Sort of looks like your installation media is goofed up. Did you use something like win32diskimage or similar to write the ISO byte by byte? Some programs like Rufus try to create a grub which doesn’t always play nice with ISOs not expecting persistent storage.

While other ISOs (like ubuntu etc…) do play nice.

I used : dd if=xcp-ng-8.2.0.iso of=/dev/sdX bs=8M oflag=direct

should I try another way ?
(I’m on Linux Mint on my desktop)

today I tried again with another USB thumbdrive, and it worked !
weird it is picky about which thumbdrive is used apparently …
will keep in mind for the future …
thanks for the help !

Cool glad it is working - possible the first one you needed to erase all partitions / volumes, sometimes there’s some junk written in the initial sectors that DD doesn’t touch. The hint was in the log you posted a screen shot of: “cannot open root device”. Since this is happening when trying to boot from the USB drive, “root” would be the / folder on the bootable media. So tells me either the environment it creates to do a live boot is borked or the USB drive itself has some weird problems going on.