XCP-ng - guest tools fail installation on Linux Mint

Hello folks,

Getting further into my adventures with the snappy and stable XCP-ng lab setup, I ran into a hitch trying to install the Guest tools in Linux Mint. When I go to install from the mounted ISO, I get an error:

Unknown Linux Distribution linuxmint

You should manually install a version of
xe-guest-utilities which is suitable for your
distribution.

I find some of the XCP-ng documentation scarce for the tools. This worked fine on new Debian install, but fails on Mint. Any ideas?

TIA

I have never used Linux Mint but it’s Ubuntu so it’s in the package manager.
https://xcp-ng.org/docs/guests.html#linux

apt install xe-guest-utilities
1 Like

That worked great, at least for Linux Mint which uses the Ubuntu repos, thx.

I still have 2 vm’s that I couldn’t install the tools to:

Univention UCS server (based on Debian, but uses it’s own derivative repos)
Kali Linux - apparently the same issue - can’t run tools from the ISO CD because the install.sh checks for Linux version and Kali isn’t in their list and the Kali repos apparently don’t have the necessary packages.

Any ideas?

Find the deb packages and install manually.

Ok - I can do that - is there a ‘best’ or ‘right’ source for finding the right deb packages? (I have found several different sources, in the case of windows, when the xcp-ng downloads didn’t install properly I went to the Xen/Citrix downloads which worked, will it be the same for the linux support?)

The deb packages are on the xentools ISO

1 Like

XCP-ng Guest Tools install for Linux mint would be a derived Linux distribution as it is based on Ubuntu

To install the guest tools, it will need arguments added to the install command to complete the installation

This should work

bash /mnt/Linux/install.sh -d ubuntu -m 20

More here at: Guest tools | XCP-ng documentation

Kali is derived from Debian so installing the guest tools should be something like this

bash /mnt/Linux/install.sh -d debian -m 10

2 Likes