Xcp-ng from vmware

Running into an issue importing VMs from ESXi to XCP-NG using XOA.

xoa Current version: 5.82.0

xo-server 5.113.0

xo-web 5.116.1

Log message: Property description must be an object: undefined

Google searching i get old forum posts. Before i move there I wanted to know if anyone here ran into a similar issue.

Ran into this the other day. All you need to do is reboot XOA.

Also it seems that XOA must be on the same vlan as your XCP management vlan, at least in my case with the latest XO from sources and the latest XCP (I thought it worked before updates but I could be wrong.

I’m getting ready to reset my lab with fresh installs and different storage config, so I’ll be testing more when I finish.

Appreciate the feedback. I did restart XOA and still get the same error.

Whats probably important here that i didnt note is that this is on ESXi 8.0.0
Im reading a lot of success using ESXi 6.5 so the import tool probably wasnt tested on the newest release.
Aso because i am doing the trial premium, i did open a support ticket and its been kicked over to devs. Ill follow up here if i can get this working

Or if anyone else has some other workarounds would love to hear it. This isnt production right now so im willing to try whatever to get this moving along.

XCP management and XOA are on the same VLAN in my case.
Although I was thinking about placing the appliance in a separate VLAN but not sure if there is any value in that.

I don’t work with esxi, but it looks like it exports a VMDK image. If that is correct, can you use this process to convert it to VHD (not X):

It looks like I may have taken the OVA file and imported a machine directly like this:

I’m trying to remember what I did to get that one image into my system, it also didn’t work the for several tries so I don’t remember exactly what I did. I’m rebuilding my lab system so if you want to export a generic Linux image or Windows Eval image, I might be able to take a look and see if I can get something worked out.

On Xen Orchestra 5.81 , you can import vmware directly into Xen orchestra via the gui