XCP-NG change everything to other NIC

I have a MinisForum HM90 that has a 1G NIC and a 2.5G NIC. The 1G NIC is automatically recognized and I can do everything just fine with it. However, I’m trying to set up XCP-NG to use the 2.5G NIC instead. The drivers aren’t installed by default, but I’ve been able to get them added and the card detected.


yum install igc-module
xe host-list
xe pif-scan host-uuid=<HOST UUID>
xe pif-list
xe pif-plug uuid=<NIC UUID>

This gives me an eth0 network and an eth1 network. I change the management interface to the 2.5G NIC try to install XOA but for some reason I can’t get both XCP-NG and XOA to respond on the 2.5G NIC.

I’ve also tried removing the 1G NIC via pif-forget and network-destroy but then I can’t even deploy XOA.

I’m sure there’s a simple answer to this, but so far I haven’t been able to figure it out. If someone could point out what I’m missing, that would be great.

I have never tried getting a 2.5G nic to work. I just use supported 10GB NIC’s such as the Intel X520-DA2.

The 2.5G works fine. My issue is that I can’t seem to get XCP-NG to only work on the 2.5G NIC. I keep ending up where some things are on one NIC and some things are on the other, or it just completely breaks.

What I’d like to do is the following.

  1. Install XCP-NG. 1G NIC automatically recognized.
  2. Install 2.5G NIC drivers.
  3. Unplug 1G NIC.
  4. Connect 2.5G NIC.
  5. Install XOA, create VMs, etc.

Using a 10G NIC would still place me in the same position as I want to only use a single NIC for everything and I can’t seem to make that work.

My guess is some incompatibility because when we use a 10G NIC I can simply set it as the management interface.

What exactly does the management interface do? I’m able to set the 2.5G NIC as the management interface but I’m not sure what that changes and I can’t find anything regarding it in the docs.

Its the interface used for managing XCP-NG using Xen Orchestra/