XCP-NG as guest on ESXI, XCP VMs have no network [SOLVED]

I am thinking of converting my homelab from ESXi 7 to xcp-ng 8.2.

I only have one server for VMs so I can’t make a separate Xen server and migrate VMs the “easy” way.

I have a TrueNAS core box that offers VM storage as NFS.

So, as a test environment, I am trying to run xcp-ng as a guest on VMWare. I read the xcp-ng doc that says that you need to pput your ESXi port group in promiscuous mode, but that doesn’t seem to work.

I can install xcp-ng on esxi and I can connect to it via xcpp-ng Center to add my NFS data store and ISO store. When I create a VM, no matter what I try, I can’t get those nested (ESXi → XCP → VM) to have networking connected. The VM “sees” the NIC and its MAC address, but it will not pull DHCP, nor does statically setting IP information work.

What am I doing wrong? Is this even possible?

I don;t really ever use ESXI but my guess is that you don’t have it connected to the proper network. Maybe someone here more familiar with ESXI here can help.

It’s connected to the proper network, because the XCP-NG guest does have network access… Hence my ability to control it with XCP-NG Center. It’s just that any VMs created under it don’t.

I know that nested virtualization is a total crapshoot, and certainly NOT a recommended configuration. I’m just trying to do some testing to see how to do a migration from ESXi to XCP-NG (or even Proxmox if I explore that one). I’d rather NOT tear down my FUNCTIONAL infrastructure to test a different one.

One thing I noticed during an attempted Ubuntu 20.04 install is at the “network” section, it identifed eth0 and the MAC address…but it was unable to display the vendor and model of the nic.

What “brand” and “model” of NIC does xcp-ng present as virtual hardware?

You can choose either Realtek or Intel

Is that something that is only exposed in XOA? I didn’t see any choices from XCP-NG Center.

Of course, I can’t get XOA working because of the network problem… chicken and egg.

It’s something that can be changed in XO and probably from the command line as well, but it’s not something I have ever had a need to change.


The documentation on VMWare’s site is incomplete. In addition to turning on Promiscuous Mode for the Port Group, you need to accept Forged Transmits as well.

Now my Nested VMs get IPs.

TOM: I could not edit the title of this post to add [SOLVED] to it (Could not find edit button, nor a “mark as solved” button)

1 Like