XCP-NG and XO CE, install/setup-quirks?

Version used: XCP-NG 8.3beta2, latest XO CE/built from source as per 2024-04-04.

So, fiddling around and leaving VMware I need advise on a few quirks;

  1. XOCE console to VM, no special characters.
    I can’t get special characters (swedish keyboard) to work in the console. Ie password creation and usage in console sessions is “less than ideal”.
    A "shift + “1” for exclamation mark, ie “!”, it gets interpreted as a “1” and so forth.
    Currently I use XenCenter console functionality to get around this, but that does not feel like a long term solution.
    Known issue to anyone? I’ve tried MS Edge, Librewolf and Thorium as browsers.

  2. NFS as ISO SR.
    NFS at ordinairy SR for VMs is working just fine, but cannot get NFS to work as ISO SR.
    Anyone else?
    As per another thread around here I went forward with SMB as ISO SR, and it works fine. Shall I just accept the annoyance?

  3. Bonds, no physical link.
    When creating a network bond, the bond gets no physical link, and therefore no overlaying VLAN-tagged network either.
    The type/methond, slb/lacp of bonding have no effect. (dont want to say it, but the same physical switchports were used in ESXi with active/standby successfully. Therefore Im whining about it here :slight_smile: )
    Note, creating a VLAN-tagged network on to a unbonded NIC works just fine.

When creating the bond, the physical NIC’s are unused, but have physical connection.
Any quirk, like a reboot or some sort of scan needed?

Thanx in advance,

As an English only person, I have no idea about foreign keyboards, I have noticed posts in their forums about NFS ISO issue but I am not sure what circumstances lead to that as I have 5 lab systems using Synology and TrueNAS as NFS but I am unable to reproduce. I am less sure about the bonding issues because neither our production or lab systems are currently using that but we have set it up for clients and have not noticed the issue.

On a US-English keyboard the ! definitely works for both XO password and when entering in a console, I do this on both Windows Server and Debian VMs. I’m guessing this is a localization issue, I’d like to think there is a fix for this but not sure what that fix would be.

I’m a Windows shop so I just used SMB for the ISO shares, generally you don’t get into the ISO share that often so not really a big deal to me.

I have never tried to create a bonded connection and not sure I have enough resources in my lab to try. Probably a good idea from a failure standpoint.

Since you are testing, a reboot is always a good test to see what happens, even if it shouldn’t be needed. I’d try and see.

One other thing to try, maybe install a pre-built XO-CE from Ronivay, there is a chance it might work and only takes a few minutes to get it installed and working. You can always delete it later and it won’t interfere with other XO-CE installs.

And you could try the official XOA during the demo period to see if it fixes anything, there is a link to install it from the XO-Lite pages built into each XCP 8.3 beta install, just open a browser and go to a host IP and enter passwords, etc. If you have a pool, I’d go to the pool master to install XOA, also there is a script to grab it that can be run on the host terminal, just like the XO-CE image linked above.

Not saying it will fix everything, but it might fix the keyboard problem. And I’m willing to bet there are a few things that XCP can not do compared to vmWare.

Thanx for input guys.

The keyboard issue got solved after updatering a old version of mRemoteNG to a newer one. The XO-CE is reached via a jump host.

And, while asking, Im used to separete migration traffic from management traffic but do not find any obvious option for this. At least between hosts within one Pool.


Under Advanced settings for the pool, you can specify migration and backup network

1 Like