XCP-NG 8.3 to 8.3 Beta2

Can someone tell me how to upgrade? Do I need the ISO or can I upgrade via CLI? I tried Yum Update but nothing there. Thanks and sorry if this is a dumb question.

If you are doing the yum update or installing the patches via Xen Orchestra then you are on the latest version.

It has the latest update up to 8.3. However I want to install 8.3 Beta 2. To take advantage of the V-TPM. Right now I do not have that feature. I just do not know how to migrate from 8.3 to 8.3 Beta 2. Thanks for the help. I read the instructions from their website but cannot make sense of them or more importantly do not want to risk ruining a working system.

8.3 has V-TPM available from the beginning. Are you sure your xen orchestra is up to date?

You could be right, maybe XO is not up to date. I know XCP-NG is, but did not consider XO. Let me check and report back.

Thank you both for the assistance, the problem was that XO was not updated. I updated and now I am able to use latest features.

1 Like

Lots of updates to 8.3 beta lately, nice to see a lot of work going on!!!

I did notice that XO-lite was listed as updated, I didn’t really see anything different (functionally) when I checked. Really hoping this gets to feature parity (or better) with XCP-center, that was an initial goal they had.

General question probably not for a separate post but…with all the VMware integrations going on and XOSTOR is it safe to assume we won’t be seeing 8.3 or XO 6 anytime soon? Q4 maybe?

That is probably a question to post the xcpng forums. Oliver would probably tel you.

8.3 as a release? Not sure, especially as they are tending to long term releases.

Last I read about XO6 was either 3rd and 4th quarter of the year, same for XO-lite.

Would I run 8.3 beta in production? So far the answer would be yes except for the many updates that are happening. It has not broken my lab system in almost a year of running it, and not seeing any impact other than more frequent updates. And with rolling pool updates, not really a big deal. That said, my production system is on the 8.2 LTS, it was running this before I went to beta on my lab, so it stays.