XCP-NG 10G Connection Issue

I’m new to xcp-ng and Linux. I built an xcp-ng server based on one of Tom’s videos.
It has 2 intel 10g nics on the motherboard and a mellanox MCX512A-ACAT 10G card with 2 SFP ports that are connected to a unifi 10G aggregate switch with unifi 10G dac cables. The intel ports are connected with Cat6 patch cable to the unfi Aggregate switch that has 6com sfp to rj45 inserts. I have a Synology Nas with a 10G card in it connected to the AGGR switch via cat 6 cable and a unifi 10G sfp to rj45.
All ports report 10G in Xcpng. I have the guest tools installed on all VMs. Doing Iperf tests to the NAS on any of the ports gets me a max of 3.7 gig. Connecting between hosts gets me even a lower rate. I have tried all 4 ports and none get close to 10G. Not sure if the 6com sfp are junk, or if it’s a driver issue.
Any suggestions would be helpful.


Hard to say, it might be an issue with the RJ45 SFP connectors.

I also tested between the 2 Melnick ports that are using the UniFi dad cables and got the same result which should be eliminating the Rj45 I would think. Maybe the Melnox doesn’t like the UniFi dad cables