Windstream fiber -> Adtran 411 -> PfSense slow upload speed

Just had windstream fiber installed:

ont → windstream gateway → laptop = full synchronous speeds as advertised
ont → windstream gateway → pfsense = downloads speeds are as advertised, upload is 3mbps
ont → pfsense = downloads speeds are as advertised, upload is 3mbps


Are there any special settings I need to get this working properly?

pfsense box:
2.6.0 on a [HYVE ZEUS V1 1U SERVER 2x XEON 8 CORE E5-2650V2 2.6GHz 32GB RAM

riser card with CX312A Mellanox MCX312A-XCBT ConnectX-3 EN Dual Port 10 Gigabit. One is LAN other is WAN.

I have the ONT → cat 6 → 10G SFP+ RJ45 Copper → mellanox card

It’s been working great with cox for years up to 40mbps upload. Not sure why this is going so slow.

Here are my network interface settings:

Also I’ve tried to force link speed and duplex and still no go… right now its auto negotiating to 10Gbase-CX4 <full-duplex,rxpause,txpause>

Currently i’m playing with those offload settings… toggling different ones and still no go

Is this a fresh install of the latest pfsense? If it were me I would not be poking around the offload settings. Have you setup any limiters or floating rules on your interfaces?

fresh install of 2.7.0 as a troubleshooting step

it turned out to be the mellanox NIC. I tested another one and had no issues. I ordered an Intel X520-DA2 and will see how that works when it gets here.