Windows 7 & Server 2008 R2 updates break "Named PC" Sharing

On or about Jan 9 several of my clients received Important Updates on their Windows 7 PC’s. The next morning I was inundated with calls saying that they were unable to connect to the server or unable to print to a remote printer.

As a quick fix, I configured static IP addresses on all PC’s and setup mapped drives to the shares via the IP addresses.

When I had time (after getting several clients up and running again) I was able to investigate and found the problem to be KB4480980 and/or KB4480063. I haven’t stopped long enough to determine which update is the culprit, I just uninstalled both and blocked them from reinstalling.

1 Like

Invalid Handle is up there with Object reference not set to an instance of an object. with reference to obtuse error messages.

This is also broken on Server 2008 R2. Uninstalled “Security Update for Microsoft Windows (KB 4480970)” and prevented it from reinstalling.

I had this issue this morning with one of my client’s computers. Just one of them updated and they weren’t allowed to access any remote folders, even though their user had full permissions. Gave them admin access in AD and it fixed the issue. Need to investigate what update is broken.

Have you tried the solution found in the KB article?

After you apply this update, the network interface controller may stop working on some client software configurations. This occurs because of an issue related to a missing file, oem<number>.inf. The exact problematic configurations are currently unknown. 1. To locate the network device, launch devmgmt.msc. It may appear under Other Devices .
2. To automatically rediscover the NIC and install drivers, select Scan for Hardware Changes from the Action menu.

  • Alternatively, install the drivers for the network device by right-clicking the device and choosing Update . Then choose Search automatically for updated driver software or Browse my computer for driver software .

In all of the cases I have worked on, the NIC had never failed.

1 Like

Though it does sound like networking related issues given the diversity of services your customers are unable to reach. Couldn’t hurt to try the solution, shouldn’t take long to test.

Though I can honestly say I haven’t had any good experiences with these meltdown/spectre-esq patches on any O/S, hope you find a solution.

Removing the Update is the solution, had to figure this one out last Wednesday when the news had not yet emerged about the M$ cockup!