WiFi Adapter Stopped Working

#1

The WiFi adapter in my son’s Dell Precision 5520 (OS Ubuntu 16.04) appears to have stopped working.

$ ip a

shows the wlan interface is no longer there

$ dpkg -l | grep wifi

shows the 8265 drivers are installed so I’m thinking the wifi adapter (Intel AC-8265) is bad. An exact replacement from NewEgg could take up to 18 days to receive; also, there appear to be updated M.2 wifi versions available. He’s a high school senior on the robotics team in the middle of competition and uses the computer daily, so I’d like to get it fixed ASAP.

Other than swapping in a known working card, how can I confirm that the issue is, in fact, the wifi adapter? Should I stick with exact replacement or use opportunity to upgrade to newer? The computer is beyond Dell warranty period.

#2

We swap with known good to test, it’s the easiest way to handle that.

#3

Thanks Tom. I don’t have an extra adapter. Been trying to phone Dell and am laughing at how pathetic they are- can’t get through to any human. “That department is closed, please call next business day.” Open palm insert face.

#4

@LTS_Tom
What about a USB WiFi or WiFi Dongle as a temporary solution?

#5

I disconnected the WiFi card from the mount as a dry-run, but when re-mounting I’m not sure that the little metal bracket touching the two wires is correct. Should have photographed first. Does this look correct?

#6

I booted on a live usb with Kubuntu and the wifi adapter shows up and is working just fine. There is nothing wrong with the WiFi adapter. The issue with the Ubuntu install, but I don’t know what I can do to troubleshoot it.

#7

I would backup the system. Then try a reload. Plus the new ubuntu 19.04 is coming out next month. That is one way to rule out the hardware. Then you know it was a software issues was having.

#8

Thanks @jeff42 . The live usb experiment convinced me that the wifi card is not the problem. I tried many things yesterday to no avail. I can see in log files when then interface disappeared and it is related to an update he did which included dell packages named somerville-meta. We discussed moving his /home directory from M.2 drive to the 2nd SSD and restoring to factory settings and re-build, what Tom calls nuke&pave. However, I’ve not yet given up on trying to fix what’s broken. When I run lshw, the wifi interface is unclaimed. Seems like this should be something that could be fixed without having to restore.

$ sudo lshw -C network

*-network UNCLAIMED
description: Network controller
product: Wireless 8265 / 8275
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:02:00.0
version: 78
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress cap_list
configuration: latency=0
resources: memory:edc00000-edc01fff
*-network
description: Ethernet interface
physical id: 2
logical name: enxa44cc8f6216f
serial: a4:4c:c8:f6:21:6f
size: 1Gbit/s
capacity: 1Gbit/s
capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.08.3 duplex=full ip=192.168.3.237 link=yes multicast=yes port=MII speed=1Gbit/s

#9

Found this and this but I don’t know how to extend it to my situation.

#10

@LTS_Tom @jeff42

Wrapping up this saga. We ended up performing a Dell factory restore after moving his home folder to a new partition on an installed separate 1TB SSD. As expected, the WiFi worked perfectly after restore.

I’m NOT impressed with Dell’s spin of Ubuntu, but my son is use to it and is too busy now to deal with learning curve of new distro. I installed the following 18.04 LTS-based distros in VM for him to experiment with: Ubuntu (Gnome), Pop!_OS (I hate that name) and Kubuntu (my daily driver).

Finally, the migration of /home to a separate partition/drive turned out to be much easier than I thought; I may do that with my system for future nuke&pave.

I appreciate you both responding.

#11

What’s with Dell lately? Are they cutting back on QC? That EMC buy needs to be paid off.

#12

@g-aitc
I can’t say about QC since merger. His LT is from late 2017 and came with Ubuntu 16.04 LTS installed (current model is 5530 with 18.04 LTS). My gripe is that the OS is a Dell spin, so it lacks features and ability to install other features. For example, I could not install GParted in order to partition the SSD to move /home. The spin has app called Disks which I could not figure how to partition. I ended up using live USB of Kubuntu with KDE Partition Manager which did the job easily. I probably need to get familiar with partitioning with fdisk.

Another gripe is that after restore and running apt-update leads to a core dump! There’s a fix for it, but I’d forgot that we saw this when we purchased and set up previously. My son remembered. IMO, that’s just crap. Ubuntu should be drop-dead-simple to install.

3rd gripe, Dell spin of Ubuntu (Unity) does not enable the meta (windows key) to display Unity Dash. Again, there’s a rather non obvious workaround to make it work correctly. One headache after another.

If this were my PC, I would nuke every bit of Dell software and pave with Kubuntu. I’m hoping that my son will embrace a nuke and pave with Ubuntu 18.04 or PopOS or Kubuntu before he heads off to College in the fall. And on that point, let me brag on his accomplishment of being accepted into the class of 2023 at Cornell. He is thrilled. Will major in physics.

#13

I would look into a program call “timeshift” . It makes snapshot of your system files. So its easy to roll it back to a early system. Here is a github link https://github.com/teejee2008/timeshift Thinking you would like it.

#14

@jeff42
I used to run BackInTime on my system, but prefer straight up rsync. I hope timeshift is more like TimeMachine than Windows Restore. TimeMachine never failed me, Windows Restore always failed me. The happy discovery with having /home on another partition is that all of his settings, browser settings were right where he left off. Thanks for the tip.

#15

I forgot to add a link to a video on install it for you on linux. So, you can check out how it looks for yourself before install the package. https://www.youtube.com/watch?v=U-lMJHcjCVs

1 Like
#16

@jeff42
This would have been a perfect recovery tool - just roll back the OS to before the failure. I passed it along for my son to consider.

#17

It happened again while running an update. Dell spin nuked; Gnome installed.

#18

Did your son setup timeshit on the system. If he did can roll the system back.

#19

@jeff42
No he didn’t. Honestly he doesn’t have time to deal with the computer. Between attending school, robotics after school and homework after that the kid has been getting about 4 hours sleep a day. So I am his fixer and I didn’t get a chance to evaluate timeshift before the latest “anomaly”. I don’t want to install until I’ve had a chance to evaluate it on a system I don’t depend on and can trash.

The good news straight-up Ubuntu Gnome is behaving and their team and robot are doing well in the latest competition. Finals are today. Tune in to watch! Team 1768.