Why I don't see all the features of xen orchestra unlocked as they say?


I’m a new user of xen. I would like to try it with the will to run a physical installation of Windows 10 and to make the passthrough of my graphic card,the geforce RTX 2080 ti. The first thing that I did has been to install the script located in the repository that I’ve found reading from this web site :

he says : “Therefore I would like to give you a little tip how to install Xen Orchestra – with [all features of the Enterprice and Premium Edition]”.

I’m a newbie and an hobbyst,it would be wonderful to try all the features available without to pay all the money requested. I can’t afford that big amount of money and the days given to me by the trial aren’t enough nor appropriate for my situation. I was lucky to see all the features unlocked,but it didn’t happen,as u can see below :

so,it should be exactly like this or I’m doing some mistake somewhere ? take also in consideration that I tried another script located in this repo :

where he says : “Installation is done using latest xo-server and xo-web sources by default. With this method Xen-Orchestra has all features unlocked which are normally available only with monthly fee”

again,it seems not true for me. It is open source,so I should have all the features unloacked,why I don’t see them ? Not even the dashboard I can use.

basically I ran the script of jarli01 on the client computer and then,on the same computer,I opened the web address of the xcp-ng server (that it runs on another,powerful computer),something like and then I click on xen orchestra on the left,I add all the credentials and I click on “quick deploy” and what I see is the web interface of xen orchestra but with the missing features.

1 Like

I have an install guide here for building from source.

1 Like

I’ve watched the video. I have installed the script and I reached this point :

    Starting xo-server...

waiting for port to be open

WebUI started in port 443. Make sure you have firewall rules in place to allow access.
Default username: admin@admin.net password: admin
Installation successful. Enabling xo-server to start on reboot

So,I have rebooted the computers and I have opened the website : and the website ( is the IP of the XCP-ng server),but this is what I see :

what I do next is to click on xen orchestra on the left,I add all the credentials and I click on “quick deploy” and what I see is the web interface of xen orchestra but with the missing features.

I am confused, what is the IP of the VM you are installing it on to?

you have perfectly understood the problem. I was trying to open the ip address of the pc where I’d installed XCP-ng server. I’m trying to understand how it works,since I come from a different products,like qemu,kvm and esxi.

It sounds like you are trying to install xcp-ng within a VM that runs on the xcp-ng hypervisor. Your VM should have a unique IP address similar to if it were a physical separate machine not on the hypervisor. As a bridge you could also use Xen Center which is a different GUI application that only runs on Windows. This will allow you to access the xcp-ng hypervisor and allow you graphically to install VMs within xcp-ng. It’s hard for me to know what you’ve accomplished up to this point without you specifically listing what you’ve done and where you are at. Telling me you reached up to this point following a specific guide isn’t as helpful for me as to listing where you are at.

yeah I tried also to do that,but this is not the problem. I ran xcp-ng also baremetal. I tried to open the ip address of the server,instead I should reach the ip number of the pc where I have installed xen orchestra,since I’m using two different computers.