VLANS with Pfsense and Unifi AP

Can someone help me with new controller software and using VLANS with pfsense ? Lawrence’s video on Unifi AP with VLANS shows an option that does not exist in the controller software anymore. I can’t set a VLAN tag in the wifi network settings on the controller .

I think in the new version you first need to go to Settings → Advanced Features → Network Isolation → Add Network Isolation. This will then show up under “Network” when you go to create a new WiFi network.

Nope. That doesn’t add the Vlan option under Wifi networks.

I believe they want you to create a network with a VLAN under Settings > Networks and apply that network to the wireless network under Settings > Wireless Networks > (create or edit a network) > Network. It looks like they got started cleaning up the UI in the Wireless Networks when creating or editing a network but forgot to remove the column under Wireless Networks (I had a brief moment of panic when I saw that but it seems to be working). I didn’t see anything in the release notes about this specifically though so it could be a bug. Feel free to yell at them.

1 Like

In my opinion, it is best to switch to old view, everything is much easier to setup.

I ran into this a few days ago setting up my first pfSense firewall. The new setting location is a little obtuse, but works.

@NeNo This is in the old view. In a recent update they moved some things around.

@ex1580 sorry didn’t understand you are talking about old view already.
I did it like this:

  1. In networks added new networks, type VLAN only and gave VLAN tag to each
  2. In wifi networks I selected appropriate network to bind wifi network to networks from first step

Drop down in each wifi network
Screenshot 2021-12-05 at 17.45.02

Yep, that is how you do it. What this post is about is that in Wireless Networks there used to be a box to assign a VLAN. That box is now gone without warning so people who used it are confused.

*I often edit for clarity right after posting

1 Like

Yes, I forget how it looked before :slight_smile: