Vlan has no internet

I can’t for the life of me figure this out. I’m creating new vlans, exactly how I created my working ones (or so I think) but this new vlan is not receiving internet. I made 2 new vlans and both do not have internet access. I attached a screenshot of the firewall rule. I have the vlan defined in pfsense and the unifi switch is tagged with the correct vlan id. Any help would be appreciated!

You have not given us much details on your network

Couple of things.

Does the device get an ip address in the correct range

The connection between the switch and pfsense, (trunk port) have you configured all allowed vlans on the unifi switch.

Sorry about that.

Yes, the port on my unifi switch that is connected to pfsense is set to accept all vlans. I’ve also added all vlans in the network tab for unifi. I have about 5 vlans that I originally set up a year or two ago that are working. Recently I wanted to add another vlan and it just won’t connect to the internet. I check the outbound rules on pfsense too and the newly created vlans are added automatically so I don’t think that’s it.

This video should help. If you don’t use UniFi then that is fine.

Yes I use unifi and I’ve already watched this a few times, definitely helpful and informative but doesn’t fix my issue unfortunately.

well, you need to post details.

Here’s the vlan config in pfsense.

Because I can only put 1 attached screenshot per post.

DHCP is enabled and pc pickup a valid IP.

This is the rule for the vlan in pfsense (as shown before)

Here is the port configuration on the unifi switch. I’ve tried allow, block and custom; same result - no internet.

The vlan tagged in unifi.

Here is the trunk port config on unifi.

All these configs ^ are the same as the other vlans I have that are working. I can ping the gateway when on the pc on that new vlan but no access to the internet or other vlans.

Sorry if this is spammy but I’m unable to post everything in one post unfortunately.

Looks like all my previous attachments have been rejected, looks like spam but I’m just trying to post screenshots of configs in 1 post which I’m unable to do.

Question, is the PC itself set to go to VLAN 70? If not, it’s probably picking up an IP from the default VLAN.

Try changing the Native VLAN for that switch port to the VLAN you created.

As a side note, you created the VLAN on the Unifi side, right? You have to create the VLAN under “Networks” in the Unifi controller before you can use it with a switch.

Yes, the pc is connected to port 24, set to vlan70. It pulls a valid IP.

Unifi has the network already created. If I switch to an existing vlan, not the new ones, I get internet.

Is this a Windows PC?

Humor me, revert the change on the PC and get rid of the VLAN tag you applied to it’s network interface. Then, change the native VLAN of that port in the Unifi controller to VLAN 70.

I’d suggest that the newly created vlans have not been set up identically to your older ones, you need to compare all the settings between the two side by side. Presumably when you plug in a laptop to an old vlan it gets internet, when plugged into new vlan it doesn’t.