Virtualization problems

I’m attempting to install either XCP-NG or proxmox, but neither one seems to want to install properly. The attached image is where I get hung up on proxmox, XCP-NG runs through the first step and then reboots itself when it would usually start giving you the options for the install and just keeps running through the first step (running through all the items that scroll across the screen).
It’s on computer with a ryzen. virtualization is turned on, but it seems like I’m missing something.
Any suggestions please?

What are you attempting to install this on? What setting in the BIOS?

So I’ve installed XCP-NG, ESXi, and Proxmox on laptops, desktops, and servers (rackable and tower) without having a single issue. I’m going to assume this is a misconfiguration of settings.

What are you installing the hypervisor on? i.e SSD, HDD, SATA DOMM, etc.

I’ve installed all 3 on machines in the past with no problems. I agree that it’s probably a misconfiguration of some sort, but can’t figure it out.

I’m attempting to install it on a tower computer. I’ve tried on HDD and SSD, but it’s not seeming to recognize that they’re there it seems. XCP-NG runs through all the items that it scrolls through in the first step of the install process and when it reboots it goes directly back to that step. Proxmox seems to get hung up on the screen I showed loading all the drivers after click install on the main proxmox install screen.

I have activated virtuatlization in the BIOS (it’s on an MSI B550 Gaming plus motherboard). I have tried IOMMU turned on and set to auto. I have secure boot turned off. I can’t think of any other bios settings that might be causing the issues. The bios does recognize the drive that are in the computer when I look at the bios.

Try resetting the bios to factory and make sure virtualization is enabled.

Unfortunately, that didn’t work either.

What is your installation media? USB or network? Have you tried a different usb?

I did try 2 different USB drives and get the same result.

I finally tried an older version of proxmox installer (7.4 version) and it installed perfectly fine