Verizon Fios and PFSense not speaking to each other without ISP Router

Recently got the Verizon service. And pfsense was connected directly to the ONT and was working great for the last month. With no changes recently. The internet stopped working all together even thou internal network was fine. I would reboot everything and it would come back for like 5 mins then internet would be gone again. So I connected the verizon router between ONT and PFSense and all is well so far no issue. Is there something I maybe be missing that I should have done?

So far I have turned off Gateway Monitoring, used a different monitoring IP one outside of the ISP gateway.

Offline, Packetloss: 100% Interface WAN_DHCP Gateway after 5-10 mins

Only I get the service up and running is to put the verizon router between the ONT and PFSense.
I have yet to try using DMZ in the router thou

When it goes out can you release/renew WAN IP? Ping WAN GW? Have you tried different ports on the pfsense to assign to WAN? Different cables?

I have change the cables. I havent tried the others . Will do that and report back my findings. thank you. How do I do he release/renew of the WAN IP? just reboot the ONT?

in pfsense go to Status then Interfaces and there is an option to release/renew the WAN.

Did the release/renew of WAN IP still went out after 5mins
try different port same thing
Changed the Data Payload to 3 under system/routing/gateway
DCHP Client Configuration - Turned on advance configuration and changed preset to FreeBSD default under interfaces/WAN - went up to 10 mins before it dropped again

Putting the Fios Router back between the ONT and PFSense works for some strange reason. Would recommend putting it in a DMZ?

This is an odd issue that I have not encountered before, you generally want pfsense getting the public IP. You could try posting in their forums https://forum.netgate.com/

thank you. much appreciate the effort