USB Drive Cant Mount

I have a co-worker that brought in a flash drive she was saving family pictures and videos on (not a good idea I know) says she is unable to see the drive anymore and it asks to format it. Luckily she was smart enough not to click that button.

So far I have tried SpinRite at level 2 and everything came back fine. It is currently running again at level 4 but something tells me it’s going to come back fine again. I tried mounting it in my pop os 19.10 laptop but and it seemed like it worked for a bit until it came back with unreadable sectors and refused to image anymore.

Does anyone have any other ideas as to what I could do to help this lady out? other than a data recovery service. Right now SpinRite says 20hrs to complete this level 4 (ughhh).

The .img file I have on my laptop is unable to mount right now figured I could at least get something off that since it did run for about 10-15 min. I’ll have to boot it back up to get the actual error it was throwing.

I have no experience with that app but I’ve used R-Studio before for corrupted file systems and it does an excellent job.

I have had some good luck with


If it were mine, I’d let Spinrite go the full 20 hours and finish up. It may or may not work, but I’ve had great luck with Steve’s program for many years.

1 Like

I second Photorec as well

going to give the Photorec a try since it does seem like the partition is lost. Spinrite came back with nothing but blue so thats good ish

On Linux I have had luck with test disk. It’s a little cryptic to use but it has worked for me.

1 Like

Testdisk is great for sure

1 Like