Upstream network issue?

I am having some weird network issues, seemed to have started couple days ago. How this all started, is I was trying to do some of my AWS training for Professional Certificates on Linux Academy. I have been unable to login to Linux Academy website on my main workstation since Dec 26th. I either get a generic error the error below, or it just times out. I am able to login to my Linux Academy account just fine on my Windows VM, or Fedora Laptop.

Error Encountered:

invalid_request : jwt expired

Please try again. If this error persists, please contact Support

I am currently running Pop_OS 18.10 on my main workstation. I cannot seem to get to the bottom of it. Speedtest dot net bombs out on upload test from my main workstation, works perfecting from Unifi USG, Windows VM, Linux VM and my Linux work laptop. I have tried moving network cable from 1 switch to other switch, same results, tried different network cable, same results. Tried LiveUSB (Fedora 29), same results. Same errors with USB network adapter. Iperf test shows 1.09Gbps in both directions to my server.

I just ran another test. Fast dot com seems to function correctly for speed tests. While my upload still bombs out when trying to use speedtest dot net.

In ~14 years of IT I have never seen anything like this. I have also been running Linux since late 90’s. Does not mean I am over looking something stupid, but just want to make it clear I am not new to the OS and just do not know what I am doing.

Thanks in advance,

I am not clear, you get this error when logging into Pop_OS! from the console?

Hello Tom,
I have proof read the post and made some changes. Been a very long day and did not read over it before posting.

Also to add to weirdness. When I tried to submit the edits, I got an error after 2 - 3 minutes. I hit submit again and it immediately saved. Its almost like my machine is randomly dropping outgoing packets.


Taking two shots in the dark here.

  1. Is system time and date correct?

  2. Any firewall rules locally blocking traffic?

Yes, all my systems pull NTP from my Unifi USG. No firewall setup on on the system. Also, no special rules on Unifi USG other then a few port forwards.

Well it looks like I finally tracked down my issue.

sudo sysctl -a| grep _ecn
net.ipv4.tcp_ecn = 1
net.ipv4.tcp_ecn_fallback = 1

Ran the following command:
sudo sysctl net.ipv4.tcp_ecn=2
net.ipv4.tcp_ecn = 2

Now everthing is working as it should.

1 Like