Upgrading pfsense from 2.6 to 2.7 - Failed Upgrade after rebooting a few times

I’m currently running pfSense virtualized with xcp-ng. I’ve tried to perform the upgrade from pfSense 2.6.0 to 2.7.0 using two separate methods. The first method I simply used the upgrader method, and for the second I just installed into a new VM from scratch and restored the configuration from the 2.6.0 installation. Both methods fail giving me the following:

arprequest_internal: cannot find matching address.

When this occurs, my email is constantly spammed with the following (I have arpwatch package installed):

  hostname: <unknown>
          ip address:
    ethernet address: 64:a5:c3:5b:bb:90
     ethernet vendor: <unknown>
           timestamp: Thursday, September 28, 2023 11:15:00 -0500

When doing a fresh install, I did not receive any of these errors until after I rebooted the VM.

I have no idea what to do. When this occurs the system is totally unusable when this occurs in the sense I can access the machine via command line only at the physical machine but from nowhere else on the network.

If this is in a VM then I’m sure that is the issue. There is a reason why it’s call the forbidden router when you make it a VM.

Probably true, but that wouldn’t explain why the virtualized config worked in 2.52 and 2.6. Router also seems content sitting there until configuration is restored. It then seems happy until a reboot when the error start.

Perhaps try going to PfSense Plus using a clean build of 2.5.2 or 2.6, just upgrade until you get to the Plus version. Then restore your config onto the Plus version.

I had some issue moving over to 2.7 from 2.5.2 myself, eventually I had to do a clean install and re-do my config.

How did you re-do your config exactly? Manually edit the file?

@kevdog no nothing quick, I did a fresh install and configured from scratch through the GUI. I tried restoring the old config but it did not like it at all. I did move to pfsense plus however.

My suspicion is that Netgate probably just tested for migrating from the previous version to the latest, if something fails then the logical process would be to upgrade at each version until you reach the latest.

Funnily enough, I have a second box which I messed up and couldn’t work out which version of pfsense was running, I installed 2.7 from fresh and tried to restore an older config, it failed. I’ve not looked into it anymore than that but there seems to an issue with upgrading to 2.7 from “much” older versions.