Upgraded to pfSense 2.6 now I get "Interface stopped distributing possible flapping"

So I updated pfSense from 2.5.2 to 2.6 via the GUI, that seemed to go ok, then I noticed that all the gateways were down.

Inspecting the console I noticed that I was getting an error message stating igb2, igb3, igb4. igb45 Interface stopped distributing possible flapping. These 4 interfaces are all in a LACP lagg from my pfSense box to my switch. This error doesn’t come up in 2.5.2.

Tried doing a clean install of 2.6 and restoring the config but the same error pops up.

Presumably it has something to do with the LACP/LAGG but that has been working without any issues for several versions of pfSense. Not totally sure how to resolve this. I could do a manual rebuild but that will take a considerable amount of time … Any ideas ??

I have seen a similar issue in the netgate forum post on a previous upgrade. I have linked the same below

Issues with LACP after upgrade | Netgate Forum

Basically the suggestion is to remove and add the interface to LACP group and to use a system tunable. Refer to the link for more details.

Hope this helps

@jinu thanks for that, I think I saw that last night but I didn’t get it, with a clear head now I see the solution. Will have to wait until next weekend to test this now. thanks

Ok actually tried it and it failed.

Thought I would take the lagg off, update to v2.6 then reapply the lagg. That failed too.

Roll back to 2.5.2 for now and hope the update didn’t make changes that will still keep it from working.

I’m going to guess that this is a NIC driver issue, but just a guess. Do you have an older card installed that they maybe dropped support on?

Yeah I’ve rolled back, but monkey see monkey do :slight_smile: I think that link above is along the right tracks, but I don’t understand tunables at all. The NICs are fine, they work with 2.6 no problem, but I suspect some additional steps are either required for a LAGG to work (which don’t need to be applied to 2.5.2) but are now necessary for the LAGG to work on 2.6. Though I’m stumbling in the dark to find this out.

I’m wondering if I do a clean install and do a clean build of the LAGG the required settings will be applied or if I get the same errors. I don’t have any spare kit to test this out so may post in the pfSense forum to see if someone has resolved this problem.

For anyone interested, I think I have stumbled upon a possible solution outlined here my switch has a choice of an LACP or Static LAGG, so I’m assuming that the Netgear LACP is not the same as the FreeBSD active mode LACP.

I won’t be able to test out the solution until the weekend, in the event someone else has the same problem and applies the solution it would be handy to know the result.

The automatic vs static could be the issue, or the admin-key has changed and they don’t know that they need to connect. On my Enterasys switches the auto mode seems to work well enough that I don’t mess with it.