UniFi US-8 switches offline sporadically

Since I updated my three US-8 switches from to on July 18th they intermittently drop offline. They still function as switches but the controller loses the connection and then repeatedly tries to re-adopt. A power-cycle of the US-8s is all that’s necessary to fix the problem… until next time.

All three do it (singly, never together) on average about once a week each. I can’t see any pattern in the faults or other network activity that might act as a trigger. I can’t ssh to the switches when they’re offline to troubleshoot.

Ubiquity support were responsive but not particularly helpful so I keenly await another release. In the meantime can anyone offer advice on gathering specific data about this behaviour/troubleshooting, please?


UniFi USG - Downlink to US-24-G1 - Downlink to US-16-150W then three US-8s
Self-hosted controller 6.4.54

Not an issue I have encountered, but we don’t really have many of those models deployed.

I just watched your video on Graylog for debugging UniFi. Perhaps I can grab messages in the lead-up to an event. Thanks for that.

I have a couple of US-8s and have found them somewhat “sensitive” to the version of firmware they are running. They have been running with and have been running fine (knock on wood!). I also found that I had a bad run of CAT5E (not sure if if was the cable itself or the termination) but once I replaced the cable and re-terminated (and tested!) the cable things have been fine.

1 Like

@Kryten This is super interesting. I have a UniFi network setup (cloudkey gen 2 plus, usg-pro, 48-poe) that is also experiencing random connection issues. I wouldn’t have said its the switch at first thought and would have likely leaned more towards the firewall or controller. I have chatted with Ubiquiti over the last several days, sending logs - etc, but nothing so far. My 2 switches are both running that same version. I see that a new update was released today so I will update in just a few minutes.

When I look at the switches from within the controller they aren’t report offline and the uptime isn’t showing a restart. I am not seeing that they are trying to re-adopt.

I think we might have different problems but it depends what you mean by ‘random connection issues’, @twistedpair. In my case the switches pass traffic at layer 2 but can’t connect to the controller at layer 3. I’m working on a theory that there is malformed VLAN traffic (perhaps originating from my multi-interface Home Assistant VM or from my Rako lighting bridge) that the US-8s aren’t dealing with properly.
Good to know there’s a new release of the firmware - I’ll give it a try.

That does sound like a different issue. Hopefully the new firmware fixes it for you.

Sadly, no, it hasn’t fixed my problem. Back to the drawing board.

I worked on mine pretty much the entire weekend. I totally stripped the physical network down and rebuilt it several times with latest firmware as well as rolling back the firmware and trying again. None of this made any difference.

My issue is resolved. I end up rolling back the DC to before October Microsoft patches were installed. The odd part was it was several weeks before any strange behavior and any DNS tests I ran came out fine.

All of my Ubiquiti equipment does now have the latest available firmware (controller, firewall, and switches, aps).