Unifi UDMP Pro - L2TP Windows Client Connections Dropping

Have a UDM-Pro and am still waiting for the official Wireguard roll out arriving soon. Until then I have been using the LT2P server and on MAC I can connect remotely for hours but via a Windows 11 computer the connection drops after just 3-20 minutes. It’s happening with two Windows 11 computers and for the life of me I can’t figure it out.

Tried the regedit fix of AssumeUDPEncapsulationContextOnSendRule
Tried to delete and recreate the VPN connection
Tried to change IPSec Policy Agent to Automatic

Has worked flawlessly for over a year and now it just wont stay connected. Any ideas?


Have their been any recently installed update or changes from UniFi or Microsoft recently?

We’ve always done UniFi and Microsoft updates using the regular stable releases. Never early or release candidates. Never been an issue (till now?).

Ssh into you UDM and run

swanctl --log

Then connect to the VPN and see if there is anything in there that can tell us more.

Are they coming form the same IP? L2TP will drop if more than one connection is behind the same public IP.

Hey @LTS_Tom , now that the UDM’s support WireGuard and OpenVPN will my issue be resolved by upgrading to one of those services and abandoning L2TP? THANKS!

Yes, it was the same source IP

Yes, either one of those will solve the issue.