Unifi switch does not connect printer and Aruba does


I have a good question. Yesterday we had a strange problem. Our printer went down. It was connected to a 24 port Unifi switch. We toned out the cables and turned out good. Looked at the printer, no issues. Printer is Dhcp.

Thought is was the keystone patch panel. Panel OK also.

So we plugged it into the Aruba HPE2530 48 port, and then it came up! Then plugged back in to the Unifi switch and it still works.

Anyone have any idea why?

As a note before it was plugged in to the Aruba, I got two things on the unifi switch: slow amber and also if not that no light as if no connection.

This sounds like one of those “one off” issues where somehow the switch and printer didn’t establish a connection like it was supposed for whatever reason and by unplugging and plugging it back in it worked like it was supposed too and odds are it won’t happen again.

Unless it becomes a common occurrence I wouldn’t worry about it.

1 Like

I am having a similar issue but the printers are connected to a WiFi AP. I tried many things and finally, they connected and everyone was able to print. Next day issue was back and I still haven’t been able to figure out what is the issue. I can see all the printers in the controller but I can’t ping them from the computer.


hey there…you know after looking around at the mac-addr-table on the unifi switch? I noticed that the port the printer was on was an uplink port of which it should have been on a normal port (0/3). but plugging the printer in the HPE Aruba switch it came up and looking at the mac-addr-table there showed it connected right with no port security issues.

so I cleared the table on the unifi switch (cli) and then it looks good now.

I think because I did an update for the log4j there was something not right once it rebooted. clearing my tables seemed to fix it though.