Unifi Stuck Adopting with pfSense Gateway [Solved]

hi all,
First Thank you Tom for all of your great videos they are really helpful.

I have recently setup a pfSense installation on a Protecteli box, a Unifi 8 port POE switch, and Unifi AC Pro access point to replace my ISP router. The issue I am having is that my unifi controller on my PC is stuck trying to adopt the switch and AP. If I take the pfsense box out of the loop and just use my original ISP router the controller adopts them no problem. This is how I had to original set them up. It seems something in the pfSense configuration is blocking it but I have no idea what.

Here is the basic setup
pfSense -
unmanaged switch
unifi controller v (windows 10 pc)
unifi 8 port switch
unifi access point

As you can see everything is on the same subnet and the firewall rules in pfSense are very basic. I recently added the two rules in the screen shot dealing with port 8080 on the controller in the hope that might help.

I am completely lost as to what’s going on. I have tried many of the usual suggestions when a device won’t adopt in Unifi such as SSHing into it to set the inform setting and upgrading the firmware.

Any thoughts as to what might be causing this?
Many thanks for any help.

1 Like

Per your description they are all on the same subnet wihch means it’s not a pfsense firewall issues. My guess would be Windows firewall is blocking adoption.

As tom wrote, definitly not a pfSense issue. You are on the same L2 Network so either your unmanaged switch is weird and eating broadcast up packets or the system the controller runs on have some kind of firewall / block.

Try to disable Win10 Firewall completely for testing purpose.
Connect via SSH and try issue:


If you are in a L3 enviroment in different subnets you need to either have a DNS pointing to the controller or use DHCP discover. I wrote a small tool / article for that here.

But I guess in your case it is a small thing firewall related.


Thank you both so much. That was the issue although I am confused as to why it worked before but no matter. Shutting off the PC firewall (McAfee in this case) did the trick.


I’ll add two other pieces of info.
Opening port 8080 on the local firewall is having the same effect. The controller is still able to manage them.

I did come across your article tcpip.wtf when I was troubleshooting before thanks very much for putting that out there.

1 Like