Unifi pro 24 Storage vLAN

Can the unifi switch only perform vlan with a firewall/router? Trying to do a vlan for storage only and can’t figure it out, tried van only, corporate, guest no avail.

Yes, use the VLAN Only option.

1 Like

Morning Tom tried that first and XCG host can’t ping Truenas nor the other XCP host.

Did you add the VLAN as a network in XCP-NG, or is the port untagged on the switch?

Need more info on the config.

I added the vlan interface in Truenas as well as XCP. And on the ports used (sfp+ 10GB for Truenas, and 1GB for the XCP. All of those I used vlan only profile on ports.

If you set the port to a particular VLAN then you DON’T define that same VLAN in the XCP-NG or TrueNAS, just treat it as a network interface. If you have the port set to “ALL” then you DO set the VLAN tag inside of TrueNAS & XCP-NG.

In Unifi when you’re making the profile there is a native network and a tagged network


Native network is the network for untagged devices; think printers, desktops, etc. This is the network you’d pull if you just plug something into the port. This doesn’t need to be configured in TrueNAS / XCP-NG because it is the native VLAN.

Tagged networks are designed for switches, access points, phones, etc. These do need to be defined in TrueNAS / XCP-NG because they won’t be aware of it unless told they exist.

Untagged means the switch puts the tag on the packet, tagged assumes your device can add the tag itself. Not everything can.

As Tom said, you need to define the VLANs if you use “all” because they’re all tagged.

The example above is my Access Point profile, which is slightly convoluted with “untagged” as the native network because it’s an old site that used to have a USG that doesn’t now, ignore that. Basically, the AP will pull the native VLAN of the port that it’s plugged into on my switch and allow the tagged VLANs for my wireless networks.

Figured I was doing something silly had a sick kid in my lap trying to revamp my lab, let me revisit when I get home. Tom you are a blessing lol I plan on calling one day and paying consulting fees just to speak with you.

Yeah I have my APs setup correctly with IOT and other stuff just fatigue and parenting at home. I greatly appreciate everyone’s time. I’ve slowly have gotten this lab ready and shared storage was last step. Thanks so much

Now if you guys know if we can change MTU to 9000 lol I searched and it was all over place. I know not needed for home lab just curious.

I believe you’d enable Jumbo Frame on the ports in Unifi image

Then in TrueNAS it’s in Network / Interfaces under the settings for the interface

In XCP-NG I believe it’s defined in the Networks section for the interfaces / VLAN. I don’t have XCP-NG setup right now to snag you a screenshot of that part.

I didn’t have the jumbo frame option when looking. Let me login again to verify. I saw that in article but didn’t see in my controller version.

Screenshot is from a US-8-60W so I’d hope the 24 port Pro would have it as an option. I’m on the old UI on 6.1.71. Not sure where it is on the new one.

Where I assume it would be.

What about under config → services as Jumbo Frame?


Best thread ever guess I was too concentrated on port level. Need the buyba coffee/beer/hot sauce button.

Can’t ping Truenas but waiting seems after that change on the storage vlan switch disconnected from controller.

Rma or firmware time whenever I do jumbo on storage switch can’t talk to controller

IIRC Jumbo Frames get messy going from switch to switch and are usually only enabled on storage only switches, so if you have another switch in-between the Pro and the controller, that might cause issues. Not the most familiar with them though.

The Pro line is also still fairly new so it could be a firmware thing that’s not fully fleshed out.

Likely firmware, only have 8 port poe attached for access points.