UniFi not forgetting devices

A couple of issues. The main one is UniFi is not forgetting a problematic device. I tell it to Forget the devices, but later they reappear with aliases I set before. And pressing the reset button on the device itself only seems to reset the SSH credentials. I have tried multiple times. The in-wall will automatically attempt to re-adopt itself, but will fail. Power cycling the devices does not seem to work either

The Beacon’s LEDs are white, indicating it is ready to be adopted, but the controller is saying that it is “Disconnected”.

The devices are an In-Wall HD and a BeaconHD.

Anyone know of a way to purge the database?
I restored a backup from my UDM (big mistake, whole shitshow before I managed to get most of my devices re-adopted).

I have set static IPs for all of my devices in pfSense. I could be wrong, but I don’t think that should be an issue.


We reset devices all the time, not an issue I have ever run into, UniFI has some documentation on the topic here:

I haven’t run into this kind of issue either. However after you forget it from the console you could then ssh into the device and try the “set-default” or "syswrapper.sh restore-default"command. I used the syswrapper command myself a few days ago after I forgot a few devices from a hosted cloud key but the devices were not connected at the time. This made quick work to get them ready and adoptable into a new controller.

I have already that article.

I agree it is very strange behaviour, as I was able to readopt my other 7 devices using the that article.

I have tried forgetting the WAP, then immediately running the syswrapper.sh command. No change.

Seeing as how the SSH username and password are the default ubnt, not what I have set it to. It appears to me that the controller is not deleting the config data for those 2 devices (and only those).

Maybe I’m just lucky and tripped over a rare bug. :wink:

I am currently in contact with Ubiquiti support. So far they’re just suggesting the same thing.

If they come up with a solution that resolves the issue, I will post it here.

1 Like

6 days of back & forth with Ubiquiti support, & still no closer to a resolution. In fact, it almost seems like they’re only running through a script.

In fact, I just got this response today:
"Can you please disconnect the AP from the network, forget the AP from the network application, reset the AP and then try to adopt the AP in the Network application?

To forget the AP: Click on the AP to open properties panel<<Setings<<Manage<<Forget device."

This is despite telling them in my 1st message that I have tried this multiple times before creating this support ticket. Either that, or whoever responds, doesn’t bother even skimming through the past conversation.

Update: Ticket closed without resolution. I ended up making a new VM and starting from scratch (not restoring from backup). I was very reluctant to reinstall UniFi, as I had a lot of difficulty installing it in the first place.

A few snags. Neither the .deb installer, nor the instructions on the Ubiquiti website worked, as the required version of MongoDB is not in the Debian repo, and adding an older version didn’t work.

I found a script that a Glenn R. created and posted to the Ubiquiti Community Forums that works flawlessly. I don’t know enough to properly review the script to see how it solves the above issues.

Glenn’s installation script if anyone wants to review it:

Instructions for running the script, including all of the options.