UniFi Flex Mini adoptation issue


I recently purchased 5 UniFi Flex Mini switches, but I am having trouble adding them to the UniFi Controller.
Our environment:

  • SonicWall Nsa3600 router
  • UniFi APs (13)
  • Ubiquiti switches
  • Controller in AWS on Ubuntu (inform set to public, latest stable release)

If I connect the switch it gets an IP, I can ping it. But I can’t SSH into the switch. (Error: kex_exchange_identification: Connection closed by remote host)

I tried to

  • Factory reset
  • bring home and adapt to my home controller (works and I updated the firmware)
  • use UniFi discovery tool (shows up, but I can’t set the inform address)
  • check the traffic with Wireshark: we see only
  • verifying the necessary ports are okay on the controller VM

Packet capture from SonicWall:

A few months ago I was able to adopt a 16port-POE Light Unifi switch successfully. The switch can access the FQDN of the inform. But it is suspicious that we don’t see any other traffic other than the

Did anybody had the same issue?
Thank you for your answers!


And it looks like the problem is solved.

We had to specify option 43 on our DHCP server, which is SonicWall. After that the devices showed up.

The only catch with this solution is to activate “Overwrite Inform” on the controller, so every device will have the FQDN, not just IP addresses.

The Flex Mini doesn’t offer SSH access as far as I’m aware. I had the same issue. If it’s not in the same network as the controller, you’ll need to adopt it either by using DHCP Option 43 or DNS.