UniFi Disabling 2.4GHz and AP Groups/Roaming

We currently have 24 UniFi APs and are looking at possibly expanding this by adding another 60+ APs.

I set it up initially in V5 of the controller, and disabled 2.4GHz on every other AP - This was really easy and straightforward to do and worked great.

Since moving to V6 I have lost the ability to do this, and I’m now supposed to create two “AP Groups”, one with both 2.4GHz and 5GHz enabled, and one with only 5GHz enabled. I haven’t done this, as we haven’t had any reported issues where 2.4GHz is becoming an issue. This will almost certainly become an issue when we expand the system.

I’m thinking that we are going to have an issue having two groups, and moving between two SSIDs (even though they have the same SSID) is probably going to cause the connection to drop as people move from an AP in APGroup5GHzonly and reconnect as they move to an AP in APGroup2.4&5GHz. At the moment they seamlessly roam between APs, as they are all in the same AP group.

We are using RADIUS authentication and accounting, and if it’s going to disconnect and reconnect the RADIUS session as the user moves from one AP group to the other it simply isn’t going to work for us. We’re a large school, 1800 users, 1-to-1 iPads, and people move around the building A LOT.

Has anyone got any feedback on how this works in the real world? It just seems far more difficult, having to maintain two SSIDs, rather than just being able to disable 2.4Ghz on a specific AP.

Thanks for any advice!

Instead of turning off the radios, we just lower the power but ONLY IF there is an issue.

1 Like

What’s the rational behind turning off 2.4 GHz in the first place?

There’ll no doubt be some overlapping APs, and with only 3x 2.4GHz channels, I thought it would be best to disable it on some APs as I have done in the past. I’ll have to do some testing and see how much effect setting the power to ‘low’ changes the signal strength and if this will be a workable option.

So you are saying that in the past switching from one AP to other caused problems? Would that be related to the APs or RADIUS? In case of the latter I would argue that something is wrong with the RADIUS setup.

I have no personal experience with RADIUS, but given how widespread it is, I simply cannot imagine that this scenario does not work. However, I may be utterly wrong here.

No we’ve had no issues in the past when roaming and it currently works perfectly.

The problem I’m foreseeing (might be wrong here) is currently in UniFi to disable 2.4GHz you have to setup two AP Groups. Group 1 APs have 2.4GHz and 5GHz enabled, and Group 2 APs have 5GHz only.

Each AP Group is essentially a different network, but you use the same SSID so that the same set of credentials can be used for both; essentially two different networks with the same SSID and authentication settings. The issue I see is that when the client is roaming between APs in different groups, then the connection will drop and reconnect. You also have two SSIDs to maintain, (two lots of passwords to change, or two lots of RADIUS settings to set) and no easy way of telling within the controller which is the 2.4GHz&5GHz SSID and which is the 5GHz only SSID. Roaming between APs within the same group should still work perfectly.

Doing it this way, is like having two completely separate APs, but with the same SSID and authentication. They’re sort of the same, but completely different.

(I’m not using 802.11R fast roaming)

I might be talking a load of rubbish, but it used to be so easy in Controller V5…

Perhaps it is me, but I am still at a loss why you want to disable 2.4 GHz in the first place. If you don’t want to discuss this, that is fine. But my overall experience is that quite often this kind of setup has been made to achieve a certain goal. And sometimes people maneuvered themselves into a corner, when a much simpler solution would have been possible. Hence my asking for the initial motivation of this setup.

There will be a lot of APs in relatively close proximity, and there are only 3 useable, non-overlapping 2.4GHz channels that can be used. (CH 1, CH 6, CH11)
If APs are close together, and these channels overlap, then performance will start to degrade.

If the following APs are relatively close together (or one per-room in adjacent rooms), and there are a lot of client devices, then the channels become ‘congested’ (I can’t think of a better term) and APs/clients will have to wait before they can transmit data. This then equals degradation in performance and appears as though the ‘WiFi is slow’ or ‘WiFi doesn’t work’

AP1 - CH1
AP2 - CH6
AP3 - CH11
AP4 - CH1

With the above APs, I could disable 2.4GHz on AP1 or AP4, and the problem would be solved.
Same for any APs where interference from microwaves or DECT telephones could be an issue.

It isn’t an issue on 5GHz due to the number of available channels. (Around 20+)

AP1 - CH36
AP2 - CH40
AP3 - CH44
AP4 - CH48
etc… etc…
AP12 - CH36

By the time you get to needing CH36 again, AP12 is physically nowhere near AP1 which is also on CH36. (If you’re using 40MHz channels then this won’t quite be right)

WiFi 6E takes this even further with over 50x 20MHz channels available.

I might be talking rubbish but it seems to make sense…

So you turned off 2.4GHz on half the access points as part of your network design, not because you were having a problem?

1 Like