Unifi devices not adopting on controller-new pfsense

I just setup my netgate 3100 to be my main router on my network. I followed Tom’s guidance to setup my UDM Pro. The netgate router is on and the UDM WAN port is and the UDM is on The controller can see the devices but won’t adopt them. Keep cycling offline and then back to adopt. I figured the inform url was messed up. I currently have three access points and four switches. The main 24 port POE switch has the correct inform address when I SSH into it. Status is showing timeout. This holds true for two of the AP’s but one has the default inform URL and shows unable to resolve.

I have tried resetting these devices but that has not resolved the issue either. I am wondering if I am missing a firewall rule in pfsense.

Can someone point me in the right direction?

Thanks, John

Start by making an “allow all” rule and make sure you didn’t select just TCP under the firewall rules.

iam not an unifi expert. But some time ago - i get a similar problem.

At my case it looks like an “adopting loop” - the Device was seen - adopted … Offline → then it changed back to adopting … offline.

The soultion in my case was to set up “Network application Hostname/IP” and check the box “Override Inform host with the Network application hostname/IP”

Maybe you try it with the controller IP . Or you wirte your Domain name here and point your local DNS Server to IP Adress of your controller.

Maybe it will help you.


I have allow all rules setup for both LAN and LAN2. If I use the ping feature inside pfsense and try to ping the WAN IP it fails. It does the same when I try and ping the UDM Pro IP (

I tried putting the IP address in the override inform host but that did not resolve the issue either.

Do you have it setup like I do in this video?


Well I thought I did. My problem was the LAN network on the UDM. Once I got it on the same subnet as the LAN from the pfsense everything began adopting. Thank you for pointing me in the right direction!