Unifi controller wont set name servers for network

I have looked up a few guides on how to set DNS servers for a network. I currently have the WAN DNS servers set to my Pi-Holes but every query that comes in shows up as the gateway asking. I want to be able to see what client is requesting what.
Pi-Hole 1

I set the name servers like the guides show:

Save changes (It says saved successfully) and nothing provisions:

When I check the settings, it didn’t save:

I’m not sure if I’m going wrong or if its the new Unifi Controller update. Also there are no firewall rules enabled right now so the Pi-Holes are 100% accessible from any network.