Unifi controller restore Issues

Last week I was no longer able to log into the controller. I had this happen before and I believe a database repair fixed it, but not this time. I tried restoring several different backups and they all failed, still couldn’t log in. I reset to factory defaults, got a working controller and tried several restores again with no luck. Through some digging, I found that the user had been deleted from the mongo db. I added the user back in and I can now log into the restored controller, but it just either loads a blank page with the side menu occasionally showing, or I get an opaque page of the dashboard that does nothing. Sometimes url shows as https://100000:443/manage/null/dashboard, I change the null to default and still nothing. I sometimes get errors in the browser console for the api stating no site context.
Not sure where to go from here.
Don’t really want to start from scratch, this is a cloud key gen 1, I also spun up a docker container on my Synology NAS to see if I could get it working from there.
Thanks for any help or direction you can provide.

After hours of trying found this post restore access to unifi controller · GitHub

This fixed the problem. If you are running a more current version 6.4 or higher I believe scroll all the way to the bottom for some modifications you need to make for higher versions. That’s the piece I was missing.

1 Like