Unifi controller not adopting devices after site migration


I am having some trouble with my UnifI controller and it not adopting my devices. I have just migrated them to a new Unifi controller, they say adopting, then the status goes to disconnected, then it attempts to adopt them again.
The controller was doing this with the same ip as the original controller and the ip that was assigned to it. (I set the ip to the original controllers ip when the original controller was shut down).

The new controller is the linuxserver.io Unifi controller (link ) and the old one was not the docker version of the controller.
Would it be worth just buying a cloud key instead of worrying about hosting the controller on linux?
I am happy to provide any more details about the setup if needed.

Any help will be greatly appreciated.
Thank you.

Try ssh to a device and tell it to adaopt to the controller ip or hostname

Command to adopt once connected is
set-inform http://your-server:8080/inform

More details here;

Hope this helps

Thank you for your comment. Where would i find the password for ssh. I have tried the password i used for the web ui and "unbt’. I have never used ssh on these devices before.

Edit: Sorry, i didn’t see the link to the hostifi article, i have the password and am going to try it now.

I have run the listed command to set the devices to the new controller but I’m not sure if it worked. It says provisioning then connected but then goes back to the adopting status, then disconnected then adopting again. The old controller is offline.

Try deleting the device from the controller, then run the command.

Unfortunately that didn’t work. I get a device busy because the controller is still trying to adopt it. Is there a way to force forget it?

Try following this guide as it sounds like your issue.

1 Like

Thank you so much. That fixed it and now everything adopted. i will defiantly be saving that article because it seems like an easy mistake to make when using the docker controller. Thank you once again for your time.

Np, glad its up and running.