Unbound DNS Resolver stops - pfsense

As the title states the Unbound DNS resolver keeps stopping; multiple times a day. On the latest release of 2.5.1-RELEASE (amd64). I can’t seem to find a fix for this issue on the internet. Looks like it was an issue on an earlier ver of 2.5 and I did looks the ability to resolve using DNS, but for me it didn’t happen as frequent as it is now. Any suggestions on what I can do to either restart the service automatically or on what may be causing this issue.

Seems this is known issue, thought there was some kinda fix someone wrote in the forum.

Failing that if you install the service watchdog package you can add your DNS to it, when it goes down it ought to restart automatically.

I’m running 2.5.1 but not had this issue though I have watchdog running.

I have not experienced this issue either but the forums report unchecking these two settings under Services/DNS Resolver resolve the issue for many users.

I did have “Register DHCP leases in the DNS Resolver” enabled. I did find that somewhere when originally looking as a possible workaround, but I couldn’t find the thread after looking around again. I just unchecked that option. Thanks for the help.

Thanks I was looking for a way to do this. I will look into it.

Let us know if this resolves the issue…

Unfortunately it did not as I had to reboot the router this morning to get DNS working.

Is the resolver version 1.13.1 or 1.13.0?

v 1.13.1
However, I must have never saved my settings when I unchecked DHCP registration yesterday. I unchecked that option again earlier today and made sure I hit save this time. So far, I haven’t had an issue where unbound stopped running on its own.

I have this same problem with 2.5.1 even after using watchdog to restart the service. I don’t have DHCP registration and Static DHCP too.

Do you have pfblockerng installed and running?

Yes, What I did is restore my previous config and stop automatic update. It’s now working again.

There is a issue with reloading rules every hour because the unbound service has to be bounced every time the cron runs. You can try the live reload to resolve this problem.

1 Like

I just ran into this issue this week after doing some package updates and OF COURSE this site is where I find the answer.

I’ve added the watchdog and checked the block for live updating. I’ll see if that fixes my issues.