Unable to get dhcp on vlan


I created a new vlan using my lan interface as parents. The machine using static ip can ping each other even across 2 swith with no issue. In pfsense diagnostic, I cannot ping any of my machine in my vlan5 subnet. Machine using dhcp are not getting any IPs…
Do I need to create a NAT rule for the newly added interface?

Could anyone pleas advise.

Thank you

Have you enabled the DHCP server for the new VLAN you created?

1 Like

@Tmi yes, DHCP is enable :).
What puzzle me is that I should at lease be able to ping the static IP on that vlan interface but I cannot

Did you configure your interface on your switch to utilize the new VLAN?


I tried my unifi switch and everyting seem to worked ok. Plugged the d-link back and the issue appeared again.

I think I need to figure out how vlan work in D-Link switch.

Thank you for the pointer :slight_smile:

If your D-Link does not support 802.1q VLAN’s your D-Link won’t support your VLAN. I suggest you Google your D-Link model to find out if it can be configured for VLANs.

Yes, it does. I’m looking at a few tutorials and still can’t get it to work. I’ve got the original guy that did the original install to look at it tomorrow :slight_smile: